aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-09-18 12:50:22 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-09-20 13:16:17 +0200
commitc79cb9fda71a49590dc785d7c6e1472eee134e02 (patch)
tree42ee03585d2bc2bedab9d9e7029fac9724c398f3
parentfb0c3eb5a31b891d3462311e42f5ec72b78395e8 (diff)
downloadupstream-c79cb9fda71a49590dc785d7c6e1472eee134e02.tar.gz
upstream-c79cb9fda71a49590dc785d7c6e1472eee134e02.tar.bz2
upstream-c79cb9fda71a49590dc785d7c6e1472eee134e02.zip
kernel: bump 4.19 to 4.19.73
Refreshed all patches. Remove upstreamed: - 840-media-i2c-tda1997x-select-V4L2_FWNODE.patch - 079-v4.20-ARM-dts-qcom-ipq4019-fix-PCI-range.patch - 083-ARM-dts-qcom-ipq4019-enlarge-PCIe-BAR-range.patch - 084-ARM-dts-qcom-ipq4019-Fix-MSI-IRQ-type.patch Fixes: - CVE-2019-15030 Compile-tested on: cns3xxx Runtime-tested on: cns3xxx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/brcm2708/patches-4.19/950-0691-media-vb2-set-reqbufs-create_bufs-capabilities.patch2
-rw-r--r--target/linux/gemini/patches-4.19/0008-ARM-dts-Enable-Gemini-flash-access.patch2
-rw-r--r--target/linux/generic/hack-4.19/204-module_strip.patch4
-rw-r--r--target/linux/generic/hack-4.19/930-crashlog.patch2
-rw-r--r--target/linux/generic/pending-4.19/840-media-i2c-tda1997x-select-V4L2_FWNODE.patch43
-rw-r--r--target/linux/ipq40xx/patches-4.19/079-v4.20-ARM-dts-qcom-ipq4019-fix-PCI-range.patch25
-rw-r--r--target/linux/ipq40xx/patches-4.19/083-ARM-dts-qcom-ipq4019-enlarge-PCIe-BAR-range.patch42
-rw-r--r--target/linux/ipq40xx/patches-4.19/084-ARM-dts-qcom-ipq4019-Fix-MSI-IRQ-type.patch32
9 files changed, 7 insertions, 149 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index c46ff6d61c..e2d5fbab88 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -8,11 +8,11 @@ endif
LINUX_VERSION-4.9 = .193
LINUX_VERSION-4.14 = .144
-LINUX_VERSION-4.19 = .72
+LINUX_VERSION-4.19 = .73
LINUX_KERNEL_HASH-4.9.193 = 9be5081cc0fa6b720e6b3e5cb90296f3d857469bb3cda09ff93db00f9e16fd01
LINUX_KERNEL_HASH-4.14.144 = cb8b84675ba060b249ffa62de2366d16e842e3edfcb355ebbfb06bf3de03ca54
-LINUX_KERNEL_HASH-4.19.72 = f9fcb6b3bd29115ac55fc154e300c3dce2044502732f6842ad6c25e6f9f51f6d
+LINUX_KERNEL_HASH-4.19.73 = 7db5e77ef2a2d8da4b128b7d47d7dd645ebcde2d19c1d191793e1eeefc275fab
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/brcm2708/patches-4.19/950-0691-media-vb2-set-reqbufs-create_bufs-capabilities.patch b/target/linux/brcm2708/patches-4.19/950-0691-media-vb2-set-reqbufs-create_bufs-capabilities.patch
index c08997a3b8..233857f5d1 100644
--- a/target/linux/brcm2708/patches-4.19/950-0691-media-vb2-set-reqbufs-create_bufs-capabilities.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0691-media-vb2-set-reqbufs-create_bufs-capabilities.patch
@@ -80,7 +80,7 @@ Minor modifications required on the backport
* Any -EBUSY result from vb2_verify_memory_type can be mapped to 0.
--- a/drivers/media/platform/vim2m.c
+++ b/drivers/media/platform/vim2m.c
-@@ -841,6 +841,7 @@ static int queue_init(void *priv, struct
+@@ -840,6 +840,7 @@ static int queue_init(void *priv, struct
src_vq->mem_ops = &vb2_vmalloc_memops;
src_vq->timestamp_flags = V4L2_BUF_FLAG_TIMESTAMP_COPY;
src_vq->lock = &ctx->dev->dev_mutex;
diff --git a/target/linux/gemini/patches-4.19/0008-ARM-dts-Enable-Gemini-flash-access.patch b/target/linux/gemini/patches-4.19/0008-ARM-dts-Enable-Gemini-flash-access.patch
index 372242c68b..fab00d25e5 100644
--- a/target/linux/gemini/patches-4.19/0008-ARM-dts-Enable-Gemini-flash-access.patch
+++ b/target/linux/gemini/patches-4.19/0008-ARM-dts-Enable-Gemini-flash-access.patch
@@ -27,7 +27,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
gpio-miso = <&gpio1 8 GPIO_ACTIVE_HIGH>;
gpio-mosi = <&gpio1 7 GPIO_ACTIVE_HIGH>;
- /* Collides with pflash CE1, not so cool */
- cs-gpios = <&gpio0 20 GPIO_ACTIVE_HIGH>;
+ cs-gpios = <&gpio0 20 GPIO_ACTIVE_LOW>;
num-chipselects = <1>;
@@ -253,15 +252,18 @@
diff --git a/target/linux/generic/hack-4.19/204-module_strip.patch b/target/linux/generic/hack-4.19/204-module_strip.patch
index c0650b3670..2524307f45 100644
--- a/target/linux/generic/hack-4.19/204-module_strip.patch
+++ b/target/linux/generic/hack-4.19/204-module_strip.patch
@@ -114,7 +114,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
config MODULES_TREE_LOOKUP
--- a/kernel/module.c
+++ b/kernel/module.c
-@@ -3009,9 +3009,11 @@ static int setup_load_info(struct load_i
+@@ -3016,9 +3016,11 @@ static int setup_load_info(struct load_i
static int check_modinfo(struct module *mod, struct load_info *info, int flags)
{
@@ -127,7 +127,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (flags & MODULE_INIT_IGNORE_VERMAGIC)
modmagic = NULL;
-@@ -3032,6 +3034,7 @@ static int check_modinfo(struct module *
+@@ -3039,6 +3041,7 @@ static int check_modinfo(struct module *
mod->name);
add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
}
diff --git a/target/linux/generic/hack-4.19/930-crashlog.patch b/target/linux/generic/hack-4.19/930-crashlog.patch
index 0088b7a081..1562df44a4 100644
--- a/target/linux/generic/hack-4.19/930-crashlog.patch
+++ b/target/linux/generic/hack-4.19/930-crashlog.patch
@@ -280,7 +280,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
+module_init(crashlog_init_fs);
--- a/kernel/module.c
+++ b/kernel/module.c
-@@ -256,6 +256,9 @@ static void mod_update_bounds(struct mod
+@@ -251,6 +251,9 @@ static void mod_update_bounds(struct mod
#ifdef CONFIG_KGDB_KDB
struct list_head *kdb_modules = &modules; /* kdb needs the list of modules */
#endif /* CONFIG_KGDB_KDB */
diff --git a/target/linux/generic/pending-4.19/840-media-i2c-tda1997x-select-V4L2_FWNODE.patch b/target/linux/generic/pending-4.19/840-media-i2c-tda1997x-select-V4L2_FWNODE.patch
deleted file mode 100644
index 65fcfb5bfe..0000000000
--- a/target/linux/generic/pending-4.19/840-media-i2c-tda1997x-select-V4L2_FWNODE.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 237e88dcbcb0098e1a8a0887fb7299fcf18650a5 Mon Sep 17 00:00:00 2001
-From: Koen Vandeputte <koen.vandeputte@ncentric.com>
-Date: Mon, 18 Mar 2019 17:39:26 +0100
-Subject: [PATCH] media: i2c: tda1997x: select V4L2_FWNODE
-
-Building tda1997x fails now unless V4L2_FWNODE is selected:
-
-drivers/media/i2c/tda1997x.o: in function `tda1997x_parse_dt'
-undefined reference to `v4l2_fwnode_endpoint_parse'
-
-While at it, also sort the selections alphabetically
-
-Fixes: 9ac0038db9a7 ("media: i2c: Add TDA1997x HDMI receiver driver")
-Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-Cc: Akinobu Mita <akinobu.mita@gmail.com>
-Cc: Bingbu Cao <bingbu.cao@intel.com>
-Cc: Hans Verkuil <hverkuil-cisco@xs4all.nl>
-Cc: Jacopo Mondi <jacopo+renesas@jmondi.org>
-Cc: Matt Ranostay <matt.ranostay@konsulko.com>
-Cc: Mauro Carvalho Chehab <mchehab@kernel.org>
-Cc: Robin Leblon <robin.leblon@ncentric.com>
-Cc: Rui Miguel Silva <rui.silva@linaro.org>
-Cc: Sakari Ailus <sakari.ailus@linux.intel.com>
-Cc: Tim Harvey <tharvey@gateworks.com>
-Cc: linux-kernel@vger.kernel.org
-Cc: stable@vger.kernel.org # v4.17+
----
- drivers/media/i2c/Kconfig | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
---- a/drivers/media/i2c/Kconfig
-+++ b/drivers/media/i2c/Kconfig
-@@ -60,8 +60,9 @@ config VIDEO_TDA1997X
- tristate "NXP TDA1997x HDMI receiver"
- depends on VIDEO_V4L2 && I2C && VIDEO_V4L2_SUBDEV_API
- depends on SND_SOC
-- select SND_PCM
- select HDMI
-+ select SND_PCM
-+ select V4L2_FWNODE
- ---help---
- V4L2 subdevice driver for the NXP TDA1997x HDMI receivers.
-
diff --git a/target/linux/ipq40xx/patches-4.19/079-v4.20-ARM-dts-qcom-ipq4019-fix-PCI-range.patch b/target/linux/ipq40xx/patches-4.19/079-v4.20-ARM-dts-qcom-ipq4019-fix-PCI-range.patch
deleted file mode 100644
index ecf2a4aefb..0000000000
--- a/target/linux/ipq40xx/patches-4.19/079-v4.20-ARM-dts-qcom-ipq4019-fix-PCI-range.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From da89f500cb55fb3f19c4b399b46d8add0abbd4d6 Mon Sep 17 00:00:00 2001
-From: Mathias Kresin <dev@kresin.me>
-Date: Wed, 25 Jul 2018 10:37:48 +0200
-Subject: [PATCH] ARM: dts: qcom: ipq4019: fix PCI range
-
-The PCI range is invalid and PCI attached devices doen't work.
-
-Signed-off-by: Mathias Kresin <dev@kresin.me>
-Signed-off-by: John Crispin <john@phrozen.org>
-Signed-off-by: Andy Gross <andy.gross@linaro.org>
----
- arch/arm/boot/dts/qcom-ipq4019.dtsi | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/arch/arm/boot/dts/qcom-ipq4019.dtsi
-+++ b/arch/arm/boot/dts/qcom-ipq4019.dtsi
-@@ -405,7 +405,7 @@
- #size-cells = <2>;
-
- ranges = <0x81000000 0 0x40200000 0x40200000 0 0x00100000
-- 0x82000000 0 0x48000000 0x48000000 0 0x10000000>;
-+ 0x82000000 0 0x40300000 0x40300000 0 0x400000>;
-
- interrupts = <GIC_SPI 141 IRQ_TYPE_EDGE_RISING>;
- interrupt-names = "msi";
diff --git a/target/linux/ipq40xx/patches-4.19/083-ARM-dts-qcom-ipq4019-enlarge-PCIe-BAR-range.patch b/target/linux/ipq40xx/patches-4.19/083-ARM-dts-qcom-ipq4019-enlarge-PCIe-BAR-range.patch
deleted file mode 100644
index 1283f93708..0000000000
--- a/target/linux/ipq40xx/patches-4.19/083-ARM-dts-qcom-ipq4019-enlarge-PCIe-BAR-range.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From: Christian Lamparter <chunkeey@gmail.com>
-Date: Mon, 25 Feb 2019 20:14:19 +0100
-Subject: [PATCH] ARM: dts: qcom: ipq4019: enlarge PCIe BAR range
-
-David Bauer reported that the VDSL modem (attached via PCIe)
-on his AVM Fritz!Box 7530 was complaining about not having
-enough space in the BAR. A closer inspection of the old
-qcom-ipq40xx.dtsi pulled from the GL-iNet repository listed:
-
-| qcom,pcie@80000 {
-| compatible = "qcom,msm_pcie";
-| reg = <0x80000 0x2000>,
-| <0x99000 0x800>,
-| <0x40000000 0xf1d>,
-| <0x40000f20 0xa8>,
-| <0x40100000 0x1000>,
-| <0x40200000 0x100000>,
-| <0x40300000 0xd00000>;
-| reg-names = "parf", "phy", "dm_core", "elbi",
-| "conf", "io", "bars";
-
-Matching the reg-names with the listed reg leads to
-<0xd00000> as the size for the "bars".
-
-BugLink: https://www.mail-archive.com/openwrt-devel@lists.openwrt.org/msg45212.html
-Reported-by: David Bauer <mail@david-bauer.net>
-Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
----
-
---- a/arch/arm/boot/dts/qcom-ipq4019.dtsi
-+++ b/arch/arm/boot/dts/qcom-ipq4019.dtsi
-@@ -405,8 +405,8 @@
- #address-cells = <3>;
- #size-cells = <2>;
-
-- ranges = <0x81000000 0 0x40200000 0x40200000 0 0x00100000
-- 0x82000000 0 0x40300000 0x40300000 0 0x400000>;
-+ ranges = <0x81000000 0 0x40200000 0x40200000 0 0x00100000>,
-+ <0x82000000 0 0x40300000 0x40300000 0 0x00d00000>;
-
- interrupts = <GIC_SPI 141 IRQ_TYPE_EDGE_RISING>;
- interrupt-names = "msi";
diff --git a/target/linux/ipq40xx/patches-4.19/084-ARM-dts-qcom-ipq4019-Fix-MSI-IRQ-type.patch b/target/linux/ipq40xx/patches-4.19/084-ARM-dts-qcom-ipq4019-Fix-MSI-IRQ-type.patch
deleted file mode 100644
index b5492c9f98..0000000000
--- a/target/linux/ipq40xx/patches-4.19/084-ARM-dts-qcom-ipq4019-Fix-MSI-IRQ-type.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From: Niklas Cassel <niklas.cassel@linaro.org>
-Subject: [PATCH] ARM: dts: qcom: ipq4019: Fix MSI IRQ type
-Date: Thu, 24 Jan 2019 14:00:47 +0100
-
-The databook clearly states that the MSI IRQ (msi_ctrl_int) is a level
-triggered interrupt.
-
-The msi_ctrl_int will be high for as long as any MSI status bit is set,
-thus the IRQ type should be set to IRQ_TYPE_LEVEL_HIGH, causing the
-IRQ handler to keep getting called, as long as any MSI status bit is set.
-
-A git grep shows that ipq4019 is the only SoC using snps,dw-pcie that has
-configured this IRQ incorrectly.
-
-Not having the correct IRQ type defined will cause us to lose interrupts,
-which in turn causes timeouts in the PCIe endpoint drivers.
-
-Signed-off-by: Niklas Cassel <niklas.cassel@linaro.org>
-Reviewed-by: Bjorn Andersson <bjorn.andersson@linaro.org>
----
-
---- a/arch/arm/boot/dts/qcom-ipq4019.dtsi
-+++ b/arch/arm/boot/dts/qcom-ipq4019.dtsi
-@@ -408,7 +408,7 @@
- ranges = <0x81000000 0 0x40200000 0x40200000 0 0x00100000>,
- <0x82000000 0 0x40300000 0x40300000 0 0x00d00000>;
-
-- interrupts = <GIC_SPI 141 IRQ_TYPE_EDGE_RISING>;
-+ interrupts = <GIC_SPI 141 IRQ_TYPE_LEVEL_HIGH>;
- interrupt-names = "msi";
- #interrupt-cells = <1>;
- interrupt-map-mask = <0 0 0 0x7>;