aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-21 14:26:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-21 14:26:35 +0000
commitc627479641e437b8c53d8e010cbacd39830f6e58 (patch)
tree3695e951bbb24899b85dbd2e87c0698c459c3005
parent2d91cb94aceca1b3937cffd4946f73bf14869a3b (diff)
downloadupstream-c627479641e437b8c53d8e010cbacd39830f6e58.tar.gz
upstream-c627479641e437b8c53d8e010cbacd39830f6e58.tar.bz2
upstream-c627479641e437b8c53d8e010cbacd39830f6e58.zip
linux/3.3: nuke the gpio_buttons patch
It is superseded by the in-kernel gpio-keys-polled driver. SVN-Revision: 31409
-rw-r--r--target/linux/generic/patches-3.3/833-gpio_buttons.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/target/linux/generic/patches-3.3/833-gpio_buttons.patch b/target/linux/generic/patches-3.3/833-gpio_buttons.patch
deleted file mode 100644
index b741b8cd57..0000000000
--- a/target/linux/generic/patches-3.3/833-gpio_buttons.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/drivers/input/misc/Kconfig
-+++ b/drivers/input/misc/Kconfig
-@@ -569,4 +569,20 @@ config INPUT_XEN_KBDDEV_FRONTEND
- To compile this driver as a module, choose M here: the
- module will be called xen-kbdfront.
-
-+config INPUT_GPIO_BUTTONS
-+ tristate "Polled GPIO buttons interface"
-+ depends on GENERIC_GPIO
-+ select INPUT_POLLDEV
-+ help
-+ This driver implements support for buttons connected
-+ to GPIO pins of various CPUs (and some other chips).
-+
-+ Say Y here if your device has buttons connected
-+ directly to such GPIO pins. Your board-specific
-+ setup logic must also provide a platform device,
-+ with configuration data saying which GPIOs are used.
-+
-+ To compile this driver as a module, choose M here: the
-+ module will be called gpio-buttons.
-+
- endif
---- a/drivers/input/misc/Makefile
-+++ b/drivers/input/misc/Makefile
-@@ -53,3 +53,4 @@ obj-$(CONFIG_INPUT_WISTRON_BTNS) += wist
- obj-$(CONFIG_INPUT_WM831X_ON) += wm831x-on.o
- obj-$(CONFIG_INPUT_XEN_KBDDEV_FRONTEND) += xen-kbdfront.o
- obj-$(CONFIG_INPUT_YEALINK) += yealink.o
-+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o