aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChukun Pan <amadeus@jmu.edu.cn>2023-04-25 23:06:20 +0800
committerDaniel Golle <daniel@makrotopia.org>2023-05-29 13:04:14 +0100
commitc55bcf777226dd43620d351c54008b43824b4303 (patch)
tree20b8c2007539d2db11119f2c5d200a44dd045528
parent5d0d04e2384ebd54d14e1f5d80ad74602f8fc17f (diff)
downloadupstream-c55bcf777226dd43620d351c54008b43824b4303.tar.gz
upstream-c55bcf777226dd43620d351c54008b43824b4303.tar.bz2
upstream-c55bcf777226dd43620d351c54008b43824b4303.zip
mediatek: filogic: add uboot build for mt7981
Rename previous uboot build to mt7986-*. Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn> (cherry picked from commit c620409d58a29d49ceccf838e90e030610c06611) Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--target/linux/mediatek/image/filogic.mk40
1 files changed, 24 insertions, 16 deletions
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index fac72a1b37..da0d81c346 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -6,11 +6,19 @@ define Image/Prepare
echo -ne '\xde\xad\xc0\xde' > $(KDIR)/ubi_mark
endef
-define Build/bl2
+define Build/mt7981-bl2
+ cat $(STAGING_DIR_IMAGE)/mt7981-$1-bl2.img >> $@
+endef
+
+define Build/mt7981-bl31-uboot
+ cat $(STAGING_DIR_IMAGE)/mt7981_$1-u-boot.fip >> $@
+endef
+
+define Build/mt7986-bl2
cat $(STAGING_DIR_IMAGE)/mt7986-$1-bl2.img >> $@
endef
-define Build/bl31-uboot
+define Build/mt7986-bl31-uboot
cat $(STAGING_DIR_IMAGE)/mt7986_$1-u-boot.fip >> $@
endef
@@ -99,24 +107,24 @@ define Device/bananapi_bpi-r3
nor-preloader.bin nor-bl31-uboot.fip \
sdcard.img.gz \
snand-preloader.bin snand-bl31-uboot.fip
- ARTIFACT/emmc-preloader.bin := bl2 emmc-ddr4
- ARTIFACT/emmc-bl31-uboot.fip := bl31-uboot bananapi_bpi-r3-emmc
- ARTIFACT/nor-preloader.bin := bl2 nor-ddr4
- ARTIFACT/nor-bl31-uboot.fip := bl31-uboot bananapi_bpi-r3-nor
- ARTIFACT/snand-preloader.bin := bl2 spim-nand-ddr4
- ARTIFACT/snand-bl31-uboot.fip := bl31-uboot bananapi_bpi-r3-snand
+ ARTIFACT/emmc-preloader.bin := mt7986-bl2 emmc-ddr4
+ ARTIFACT/emmc-bl31-uboot.fip := mt7986-bl31-uboot bananapi_bpi-r3-emmc
+ ARTIFACT/nor-preloader.bin := mt7986-bl2 nor-ddr4
+ ARTIFACT/nor-bl31-uboot.fip := mt7986-bl31-uboot bananapi_bpi-r3-nor
+ ARTIFACT/snand-preloader.bin := mt7986-bl2 spim-nand-ddr4
+ ARTIFACT/snand-bl31-uboot.fip := mt7986-bl31-uboot bananapi_bpi-r3-snand
ARTIFACT/sdcard.img.gz := mt7986-gpt sdmmc |\
- pad-to 17k | bl2 sdmmc-ddr4 |\
- pad-to 6656k | bl31-uboot bananapi_bpi-r3-sdmmc |\
+ pad-to 17k | mt7986-bl2 sdmmc-ddr4 |\
+ pad-to 6656k | mt7986-bl31-uboot bananapi_bpi-r3-sdmmc |\
$(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),\
pad-to 12M | append-image-stage initramfs-recovery.itb | check-size 44m |\
) \
- pad-to 44M | bl2 spim-nand-ddr4 |\
- pad-to 45M | bl31-uboot bananapi_bpi-r3-snand |\
- pad-to 49M | bl2 nor-ddr4 |\
- pad-to 50M | bl31-uboot bananapi_bpi-r3-nor |\
- pad-to 51M | bl2 emmc-ddr4 |\
- pad-to 52M | bl31-uboot bananapi_bpi-r3-emmc |\
+ pad-to 44M | mt7986-bl2 spim-nand-ddr4 |\
+ pad-to 45M | mt7986-bl31-uboot bananapi_bpi-r3-snand |\
+ pad-to 49M | mt7986-bl2 nor-ddr4 |\
+ pad-to 50M | mt7986-bl31-uboot bananapi_bpi-r3-nor |\
+ pad-to 51M | mt7986-bl2 emmc-ddr4 |\
+ pad-to 52M | mt7986-bl31-uboot bananapi_bpi-r3-emmc |\
pad-to 56M | mt7986-gpt emmc |\
$(if $(CONFIG_TARGET_ROOTFS_SQUASHFS),\
pad-to 64M | append-image squashfs-sysupgrade.itb | check-size |\