aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-22 08:57:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-22 08:57:40 +0000
commitc4979908344bc5d49e6b8ebef003b3c32d6bd284 (patch)
treebd0c3bb9de5cb2ad0cd6f10422188e036d6d6343
parent43f485f334ce60bb1bacffa11795100475e92ec4 (diff)
downloadupstream-c4979908344bc5d49e6b8ebef003b3c32d6bd284.tar.gz
upstream-c4979908344bc5d49e6b8ebef003b3c32d6bd284.tar.bz2
upstream-c4979908344bc5d49e6b8ebef003b3c32d6bd284.zip
build: use ONESHELL to speed up scanning and the toplevel makefile
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43021
-rw-r--r--Makefile1
-rw-r--r--include/scan.mk1
-rw-r--r--include/target.mk1
3 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 91b6946ac3..f75fc7fda4 100644
--- a/Makefile
+++ b/Makefile
@@ -15,6 +15,7 @@ empty:=
space:= $(empty) $(empty)
$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
+.ONESHELL:
world:
include $(TOPDIR)/include/host.mk
diff --git a/include/scan.mk b/include/scan.mk
index 0998333439..2f2753f2a0 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -78,3 +78,4 @@ $(TMP_DIR)/.$(SCAN_TARGET): $(TARGET_STAMP) $(SCAN_STAMP)
FORCE:
.PHONY: FORCE
.NOTPARALLEL:
+.ONESHELL:
diff --git a/include/target.mk b/include/target.mk
index 3401f849a5..657109e75d 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -19,6 +19,7 @@ DEFAULT_PACKAGES.bootloader:=
ifneq ($(DUMP),)
all: dumpinfo
+ .ONESHELL:
endif
target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))