aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOever González <notengobattery@gmail.com>2019-01-23 21:20:55 -0600
committerChristian Lamparter <chunkeey@gmail.com>2019-01-26 21:43:06 +0100
commitc43acdf34201c33a6139eca7d3e9e3913e841b59 (patch)
tree4c95fa83611ec487c52604650510feccd4f693f0
parentad3e66753947672fd3ac06bbbb152bc5e700ee28 (diff)
downloadupstream-c43acdf34201c33a6139eca7d3e9e3913e841b59.tar.gz
upstream-c43acdf34201c33a6139eca7d3e9e3913e841b59.tar.bz2
upstream-c43acdf34201c33a6139eca7d3e9e3913e841b59.zip
mtd: add linksys_bootcount to the ipq40xx target
This commit adds the object 'linksys_bootcount_fix.o' to the ipq40xx target. This is needed for the Linksys EA6350v3 device. Without this patch, the device will switch-back between the current and the last flashed firmware every 3 (three) reboots. With this patch, the device works as expected. Signed-off-by: Ryan Pannell <ryan@osukl.com> Signed-off-by: Oever González <notengobattery@gmail.com>
-rw-r--r--package/system/mtd/src/Makefile1
-rw-r--r--package/system/mtd/src/linksys_bootcount_fix.c115
2 files changed, 116 insertions, 0 deletions
diff --git a/package/system/mtd/src/Makefile b/package/system/mtd/src/Makefile
index daeadbcd35..27044672cd 100644
--- a/package/system/mtd/src/Makefile
+++ b/package/system/mtd/src/Makefile
@@ -15,6 +15,7 @@ obj.ramips = $(obj.seama) $(obj.wrg)
obj.mvebu = linksys_bootcount.o
obj.kirkwood = linksys_bootcount.o
obj.ipq806x = linksys_bootcount.o
+obj.ipq40xx = linksys_bootcount_fix.o
ifdef FIS_SUPPORT
obj += fis.o
diff --git a/package/system/mtd/src/linksys_bootcount_fix.c b/package/system/mtd/src/linksys_bootcount_fix.c
new file mode 100644
index 0000000000..3fc38012fb
--- /dev/null
+++ b/package/system/mtd/src/linksys_bootcount_fix.c
@@ -0,0 +1,115 @@
+/*
+ * Linksys boot counter reset code for mtd
+ *
+ * Copyright (C) 2013 Jonas Gorski <jogo@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License v2
+ * as published by the Free Software Foundation.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ *
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <stddef.h>
+#include <unistd.h>
+#include <fcntl.h>
+#include <sys/mman.h>
+#include <sys/stat.h>
+#include <endian.h>
+#include <string.h>
+#include <errno.h>
+#include <stdint.h>
+
+#include <sys/ioctl.h>
+#include <mtd/mtd-user.h>
+
+#include "mtd.h"
+
+#define BOOTCOUNT_MAGIC 0x20110811
+
+struct bootcounter {
+ uint32_t magic;
+ uint32_t count;
+ uint32_t checksum;
+};
+
+static char page[2048];
+
+int mtd_resetbc(const char *mtd)
+{
+ struct mtd_info_user mtd_info;
+ struct bootcounter *curr = (struct bootcounter *)page;
+ unsigned int i;
+ int last_count = 0;
+ int num_bc;
+ int fd;
+ int ret;
+
+ fd = mtd_check_open(mtd);
+
+ if (ioctl(fd, MEMGETINFO, &mtd_info) < 0) {
+ fprintf(stderr, "failed to get mtd info!\n");
+ return -1;
+ }
+
+ num_bc = mtd_info.size / 16;
+
+ for (i = 0; i < num_bc; i++) {
+ pread(fd, curr, sizeof(*curr), i * 16);
+
+ if (curr->magic != (BOOTCOUNT_MAGIC) && curr->magic != 0xffffffff) {
+ fprintf(stderr, "unexpected magic %08x, bailing out\n", curr->magic);
+ goto out;
+ }
+
+ if (curr->magic == 0xffffffff)
+ break;
+
+ last_count = curr->count;
+ }
+
+ /* no need to do writes when last boot count is already 0 */
+ if (last_count == 0)
+ goto out;
+
+
+ if (i == num_bc) {
+ struct erase_info_user erase_info;
+ erase_info.start = 0;
+ erase_info.length = mtd_info.size;
+
+ /* erase block */
+ ret = ioctl(fd, MEMERASE, &erase_info);
+ if (ret < 0) {
+ fprintf(stderr, "failed to erase block: %i\n", ret);
+ return -1;
+ }
+
+ i = 0;
+ }
+
+ memset(curr, 0xff, 16);
+
+ curr->magic = BOOTCOUNT_MAGIC;
+ curr->count = 0;
+ curr->checksum = BOOTCOUNT_MAGIC;
+
+ ret = pwrite(fd, curr, 16, i * 16);
+ if (ret < 0)
+ fprintf(stderr, "failed to write: %i\n", ret);
+ sync();
+out:
+ close(fd);
+
+ return 0;
+}