aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2019-08-24 14:02:31 +0200
committerFelix Fietkau <nbd@nbd.name>2019-08-26 18:21:13 +0200
commitc3a78955f34a61d402044f357f54f21c75a19ff9 (patch)
treecef612184685e92313a8263feab83712d40326e7
parent0e22e14b6c11a1adf0316f891c9abc6a7b407c5e (diff)
downloadupstream-c3a78955f34a61d402044f357f54f21c75a19ff9.tar.gz
upstream-c3a78955f34a61d402044f357f54f21c75a19ff9.tar.bz2
upstream-c3a78955f34a61d402044f357f54f21c75a19ff9.zip
kernel: move crypto-arc4 into a module
It is no longer required by wireless drivers, so we can save some space here Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--package/kernel/linux/modules/crypto.mk11
-rw-r--r--package/kernel/linux/modules/fs.mk1
-rw-r--r--package/kernel/linux/modules/netsupport.mk2
-rw-r--r--target/linux/generic/config-4.142
-rw-r--r--target/linux/generic/config-4.192
-rw-r--r--target/linux/generic/config-4.92
6 files changed, 16 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 17cb98302d..dc7eb77986 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -46,6 +46,17 @@ endef
$(eval $(call KernelPackage,crypto-aead))
+define KernelPackage/crypto-arc4
+ TITLE:=ARC4 cipher CryptoAPI module
+ KCONFIG:=CONFIG_CRYPTO_ARC4
+ FILES:=$(LINUX_DIR)/crypto/arc4.ko
+ AUTOLOAD:=$(call AutoLoad,09,arc4)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-arc4))
+
+
define KernelPackage/crypto-authenc
TITLE:=Combined mode wrapper for IPsec
DEPENDS:=+kmod-crypto-manager +kmod-crypto-null
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 12290e94b5..47170058b2 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -98,6 +98,7 @@ define KernelPackage/fs-cifs
AUTOLOAD:=$(call AutoLoad,30,cifs)
$(call AddDepends/nls)
DEPENDS+= \
+ +kmod-crypto-arc4 \
+kmod-crypto-hmac \
+kmod-crypto-md5 \
+kmod-crypto-md4 \
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index b0d1da33d1..7d8a57d11a 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -733,7 +733,7 @@ $(eval $(call KernelPackage,ipoa))
define KernelPackage/mppe
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Microsoft PPP compression/encryption
- DEPENDS:=kmod-ppp +kmod-crypto-sha1 +kmod-crypto-ecb
+ DEPENDS:=kmod-ppp +kmod-crypto-arc4 +kmod-crypto-sha1 +kmod-crypto-ecb
KCONFIG:= \
CONFIG_PPP_MPPE_MPPC \
CONFIG_PPP_MPPE
diff --git a/target/linux/generic/config-4.14 b/target/linux/generic/config-4.14
index d80b8f71c2..ad03fd8994 100644
--- a/target/linux/generic/config-4.14
+++ b/target/linux/generic/config-4.14
@@ -882,7 +882,7 @@ CONFIG_CRYPTO_ALGAPI=y
CONFIG_CRYPTO_ALGAPI2=y
# CONFIG_CRYPTO_ANSI_CPRNG is not set
# CONFIG_CRYPTO_ANUBIS is not set
-CONFIG_CRYPTO_ARC4=y
+# CONFIG_CRYPTO_ARC4 is not set
# CONFIG_CRYPTO_AUTHENC is not set
CONFIG_CRYPTO_BLKCIPHER=y
CONFIG_CRYPTO_BLKCIPHER2=y
diff --git a/target/linux/generic/config-4.19 b/target/linux/generic/config-4.19
index 70c7af9434..80e3b52f47 100644
--- a/target/linux/generic/config-4.19
+++ b/target/linux/generic/config-4.19
@@ -926,7 +926,7 @@ CONFIG_CRYPTO_ALGAPI=y
CONFIG_CRYPTO_ALGAPI2=y
# CONFIG_CRYPTO_ANSI_CPRNG is not set
# CONFIG_CRYPTO_ANUBIS is not set
-CONFIG_CRYPTO_ARC4=y
+# CONFIG_CRYPTO_ARC4 is not set
# CONFIG_CRYPTO_AUTHENC is not set
CONFIG_CRYPTO_BLKCIPHER=y
CONFIG_CRYPTO_BLKCIPHER2=y
diff --git a/target/linux/generic/config-4.9 b/target/linux/generic/config-4.9
index 57e57c489b..d986ec3516 100644
--- a/target/linux/generic/config-4.9
+++ b/target/linux/generic/config-4.9
@@ -822,7 +822,7 @@ CONFIG_CRYPTO_ALGAPI=y
CONFIG_CRYPTO_ALGAPI2=y
# CONFIG_CRYPTO_ANSI_CPRNG is not set
# CONFIG_CRYPTO_ANUBIS is not set
-CONFIG_CRYPTO_ARC4=y
+# CONFIG_CRYPTO_ARC4 is not set
# CONFIG_CRYPTO_AUTHENC is not set
CONFIG_CRYPTO_BLKCIPHER=y
CONFIG_CRYPTO_BLKCIPHER2=y