aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-09-29 09:26:00 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2017-09-29 14:59:06 +0300
commitc317af777b2924c3625768eaeaaf0e9bc5eb6cc3 (patch)
tree840e5784a9fea0f10e7e843e5dcad9a369bf2422
parente64463ebde554071431514925825e2c30f2b6998 (diff)
downloadupstream-c317af777b2924c3625768eaeaaf0e9bc5eb6cc3.tar.gz
upstream-c317af777b2924c3625768eaeaaf0e9bc5eb6cc3.tar.bz2
upstream-c317af777b2924c3625768eaeaaf0e9bc5eb6cc3.zip
iw: fix build on musl host
The empty version.sh script causes a problem when run by make: make[3]: /usr/bin/env bash: Shell program not found Adding a shebang line in version.sh seems to solve it. Fixes FS#977. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
-rw-r--r--package/network/utils/iw/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/network/utils/iw/Makefile b/package/network/utils/iw/Makefile
index a578ddc98c..9b3c12beca 100644
--- a/package/network/utils/iw/Makefile
+++ b/package/network/utils/iw/Makefile
@@ -30,8 +30,7 @@ endef
define Build/Configure
echo "const char iw_version[] = \"$(PKG_VERSION)\";" > $(PKG_BUILD_DIR)/version.c
- rm -f $(PKG_BUILD_DIR)/version.sh
- touch $(PKG_BUILD_DIR)/version.sh
+ echo "#!/bin/sh" > $(PKG_BUILD_DIR)/version.sh
chmod +x $(PKG_BUILD_DIR)/version.sh
endef