aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-23 02:08:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-23 02:08:34 +0000
commitc2e873499ac1ef5152becf0541880d15e6447942 (patch)
tree87229a36d1ec4309020a5f6a5f4eb99ad8d70b8a
parent09c871262761d9e1c0aeabfce45380609c4629c1 (diff)
downloadupstream-c2e873499ac1ef5152becf0541880d15e6447942.tar.gz
upstream-c2e873499ac1ef5152becf0541880d15e6447942.tar.bz2
upstream-c2e873499ac1ef5152becf0541880d15e6447942.zip
add profile specific base-files packages - does not work with the imagebuilder yet, but will be fixed later
SVN-Revision: 9870
-rw-r--r--package/base-files/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 1ef64ac9c1..6e85bb98d9 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -18,6 +18,9 @@ include $(INCLUDE_DIR)/package.mk
ifneq ($(DUMP),1)
TARGET:=-$(BOARD)
+ ifneq ($(wildcard $(PLATFORM_DIR)/base-files-$(PROFILE) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)),)
+ TARGET:=$(TARGET)-$(PROFILE)
+ endif
LIBGCC_VERSION:=$(GCC_VERSION)
else
UCLIBC_VERSION:=<UCLIBC_VERSION>
@@ -129,10 +132,16 @@ define Package/base-files$(TARGET)/install
if [ -d $(PLATFORM_DIR)/base-files/. ]; then \
$(CP) $(PLATFORM_DIR)/base-files/* $(1)/; \
fi
+ if [ -d $(PLATFORM_DIR)/base-files-$(PROFILE)/. ]; then \
+ $(CP) $(PLATFORM_DIR)/base-files-$(PROFILE)/* $(1)/; \
+ fi
$(if $(filter-out $(PLATFORM_DIR),$(PLATFORM_SUBDIR)), \
if [ -d $(PLATFORM_SUBDIR)/base-files/. ]; then \
$(CP) $(PLATFORM_SUBDIR)/base-files/* $(1)/; \
fi \
+ if [ -d $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/. ]; then \
+ $(CP) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/* $(1)/; \
+ fi \
)
$(SED) 's,$$$$R,$(REVISION),g' $(1)/etc/banner
$(SED) 's,$$$$S,$(BOARD),g' -e 's,$$$$A,$(ARCH),g' $(1)/etc/ipkg.conf