aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-08-28 15:00:54 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-27 21:02:10 +0200
commitc1ccae54ceb6d5b5d8572e061f1159293dc25917 (patch)
treea963a6a3d3e6a3afbddd175383e9d1b963581389
parent80653f0c07aeef1c0e37c1aad828158f6e47eaee (diff)
downloadupstream-c1ccae54ceb6d5b5d8572e061f1159293dc25917.tar.gz
upstream-c1ccae54ceb6d5b5d8572e061f1159293dc25917.tar.bz2
upstream-c1ccae54ceb6d5b5d8572e061f1159293dc25917.zip
ccache: update to 4.6.3
Release Notes: https://ccache.dev/releasenotes.html#_ccache_4_6_3 Refresh patch: - 100-honour-copts.patch Signed-off-by: Nick Hainke <vincent@systemli.org> (cherry picked from commit 83ea2e11b4b7872642bc7ac587361ccd783308f2)
-rw-r--r--tools/ccache/Makefile4
-rw-r--r--tools/ccache/patches/100-honour-copts.patch2
-rw-r--r--tools/ccache/patches/110-musl-gcc12.patch32
3 files changed, 3 insertions, 35 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index 8c95fc6a50..0cf528bb5f 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=ccache
-PKG_VERSION:=4.6.2
+PKG_VERSION:=4.6.3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
-PKG_HASH:=789a2435d7fde2eaef5ec7b3ecf2366e546f764253e9999fdf008d2dd7f3b10c
+PKG_HASH:=1e3a251bb112632553b8255a78661fe526c3a16598496d51128c32b218fd8b22
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk
diff --git a/tools/ccache/patches/100-honour-copts.patch b/tools/ccache/patches/100-honour-copts.patch
index 24be22cbf0..c8f2fc0fe6 100644
--- a/tools/ccache/patches/100-honour-copts.patch
+++ b/tools/ccache/patches/100-honour-copts.patch
@@ -1,6 +1,6 @@
--- a/src/ccache.cpp
+++ b/src/ccache.cpp
-@@ -1750,6 +1750,7 @@ calculate_result_and_manifest_key(Contex
+@@ -1756,6 +1756,7 @@ calculate_result_and_manifest_key(Contex
"CPLUS_INCLUDE_PATH",
"OBJC_INCLUDE_PATH",
"OBJCPLUS_INCLUDE_PATH", // clang
diff --git a/tools/ccache/patches/110-musl-gcc12.patch b/tools/ccache/patches/110-musl-gcc12.patch
deleted file mode 100644
index 4e7784dcc8..0000000000
--- a/tools/ccache/patches/110-musl-gcc12.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From a69bdc87d7a4a7b019c4086cb007a0b48a007f4a Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 25 Aug 2022 12:36:18 -0700
-Subject: [PATCH] fix: Fix build with musl when using GCC 12 (#1145)
-
-(cherry picked from commit bb72cc26bc91bc56567dbef608088a9437f836bb)
----
- src/Config.hpp | 2 ++
- src/core/Statistics.hpp | 1 +
- 2 files changed, 3 insertions(+)
-
---- a/src/Config.hpp
-+++ b/src/Config.hpp
-@@ -25,6 +25,8 @@
-
- #include "third_party/nonstd/optional.hpp"
-
-+#include <sys/types.h>
-+
- #include <cstdint>
- #include <functional>
- #include <limits>
---- a/src/core/Statistics.hpp
-+++ b/src/core/Statistics.hpp
-@@ -22,6 +22,7 @@
-
- #include <cstdint>
- #include <string>
-+#include <ctime>
- #include <unordered_map>
- #include <vector>
-