aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-02-20 06:58:51 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-02-23 01:58:20 +0000
commitc17a68cc61a0f8a28e19c7f60b24beaf1a1a402d (patch)
tree33444d84313ebf8b6eedd1703a568f6cebfb4caf
parentd9ab3240a5f3767459a50b69708085a790128907 (diff)
downloadupstream-c17a68cc61a0f8a28e19c7f60b24beaf1a1a402d.tar.gz
upstream-c17a68cc61a0f8a28e19c7f60b24beaf1a1a402d.tar.bz2
upstream-c17a68cc61a0f8a28e19c7f60b24beaf1a1a402d.zip
dnsmasq: prefer localuse over resolvfile guesswork
This makes it clear that localuse when explicitly specified in the config will have its final say on whether or not the initscript should touch /etc/resolv.conf, no matter whatever the result of previous guesswork would be Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
-rw-r--r--package/network/services/dnsmasq/Makefile2
-rw-r--r--package/network/services/dnsmasq/files/dnsmasq.init8
2 files changed, 5 insertions, 5 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index d874296ea7..8c8427f6c1 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_UPSTREAM_VERSION:=2.80
PKG_VERSION:=$(subst test,~~test,$(subst rc,~rc,$(PKG_UPSTREAM_VERSION)))
-PKG_RELEASE:=9
+PKG_RELEASE:=10
PKG_SOURCE:=$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).tar.xz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/network/services/dnsmasq/files/dnsmasq.init b/package/network/services/dnsmasq/files/dnsmasq.init
index f65736e268..4ae71e438b 100644
--- a/package/network/services/dnsmasq/files/dnsmasq.init
+++ b/package/network/services/dnsmasq/files/dnsmasq.init
@@ -733,7 +733,7 @@ dnsmasq_start()
{
local cfg="$1"
local disabled user_dhcpscript
- local resolvfile localuse
+ local resolvfile localuse=0
config_get_bool disabled "$cfg" disabled 0
[ "$disabled" -gt 0 ] && return 0
@@ -884,13 +884,13 @@ dnsmasq_start()
config_get_bool cachelocal "$cfg" cachelocal 1
config_get_bool noresolv "$cfg" noresolv 0
- config_get_bool localuse "$cfg" localuse 0
if [ "$noresolv" != "1" ]; then
config_get resolvfile "$cfg" resolvfile /tmp/resolv.conf.auto
[ -n "$resolvfile" -a ! -e "$resolvfile" ] && touch "$resolvfile"
xappend "--resolv-file=$resolvfile"
[ "$resolvfile" = "/tmp/resolv.conf.auto" ] && localuse=1
fi
+ config_get_bool localuse "$cfg" localuse "$localuse"
config_get hostsfile "$cfg" dhcphostsfile
[ -e "$hostsfile" ] && xappend "--dhcp-hostsfile=$hostsfile"
@@ -1040,13 +1040,13 @@ dnsmasq_start()
dnsmasq_stop()
{
local cfg="$1"
- local noresolv resolvfile localuse
+ local noresolv resolvfile localuse=0
config_get_bool noresolv "$cfg" noresolv 0
- config_get_bool localuse "$cfg" localuse 0
config_get resolvfile "$cfg" "resolvfile"
[ "$noresolv" = 0 -a "$resolvfile" = "/tmp/resolv.conf.auto" ] && localuse=1
+ config_get_bool localuse "$cfg" localuse "$localuse"
[ "$localuse" -gt 0 ] && ln -sf "/tmp/resolv.conf.auto" /tmp/resolv.conf
rm -f ${BASEDHCPSTAMPFILE}.${cfg}.*.dhcp