aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-02-14 22:18:35 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-02-14 22:18:35 +0000
commitbeb7f2ac7b5c617cd3e1b0060c15b1e71f8faa5c (patch)
treec490bc40085d5fabb2e610183bd64fa759622b3b
parent823ac639edd5a50655390ab2eecb92823ed64794 (diff)
downloadupstream-beb7f2ac7b5c617cd3e1b0060c15b1e71f8faa5c.tar.gz
upstream-beb7f2ac7b5c617cd3e1b0060c15b1e71f8faa5c.tar.bz2
upstream-beb7f2ac7b5c617cd3e1b0060c15b1e71f8faa5c.zip
mvebu: fix WRT1900AC ubinized images
The current pxa3xx_nand driver doesn't support sub-page writing, so the VID header offset must be specified explicitly. Signed-off-by: Claudio Leite <leitec@staticky.com> Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44455 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/mvebu/image/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 3512c6a3b6..da7d2174e5 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -31,6 +31,7 @@ endef
# $(3): Erase Block Size
# $(4): Page Size
# $(5): Sub-Page Size (optional)
+# $(6): VID offset (optional)
define NANDProfile
define Image/BuildKernel/Profile/$(1)
$(call Image/Build/DTB,$(2))
@@ -48,7 +49,7 @@ define NANDProfile
endef
define Image/Build/Profile/$(1)/squashfs
- $(call Image/Build/UbinizeImage,$(2),,squashfs, -p $(3) -m $(4) $(if $(5),-s $(5)))
+ $(call Image/Build/UbinizeImage,$(2),,squashfs, -p $(3) -m $(4) $(if $(5),-s $(5)) $(if $(6),-O $(6)))
# The next line will be dropped, migrate your board to use a single firmware file
cp $(KDIR)/$$(IMG_PREFIX)-$(2)-squashfs-ubinized.bin $(BIN_DIR)
endef
@@ -136,7 +137,7 @@ $(eval $(call NANDProfile,XP-DB,armada-xp-db,512KiB,4096))
$(eval $(call NANDProfile,XP-GP,armada-xp-gp,512KiB,4096))
# Boards with NAND, with subpages
-$(eval $(call NANDProfile,Mamba,armada-xp-mamba,128KiB,2048,512))
+$(eval $(call NANDProfile,Mamba,armada-xp-mamba,128KiB,2048,512,2048))
# Boards with large NOR, where we want to use UBI
$(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB))
@@ -145,7 +146,7 @@ $(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB)
$(eval $(call NORProfile,385-RD,armada-385-rd,256KiB))
define Image/Build/Profile/Mamba/squashfs
- $(call Image/Build/UbinizeImage,armada-xp-mamba,,squashfs, -p 128KiB -m 2048 -s 512)
+ $(call Image/Build/UbinizeImage,armada-xp-mamba,,squashfs, -p 128KiB -m 2048 -s 512 -O 2048)
( \
dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \
dd if=$(KDIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-ubinized.bin \