aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-03-02 19:20:29 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-03-02 19:20:29 +0000
commitba9bc394c746fc3cf06976dd5bfc0d939fea7708 (patch)
tree6a36add7cec73d4024cfc317eefdef57a9b36d00
parent09b4a9572c720b722992752e091681e344f1211d (diff)
downloadupstream-ba9bc394c746fc3cf06976dd5bfc0d939fea7708.tar.gz
upstream-ba9bc394c746fc3cf06976dd5bfc0d939fea7708.tar.bz2
upstream-ba9bc394c746fc3cf06976dd5bfc0d939fea7708.zip
[package] firewall: move include sourcing into a subshell, this makes the firewall init immune against exit in the include scripts
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25835 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/lib/core_init.sh6
2 files changed, 5 insertions, 3 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 3d61e09889..a8a62c287d 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=22
+PKG_RELEASE:=23
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/lib/core_init.sh b/package/firewall/files/lib/core_init.sh
index c7e41e7ff7..42124b39bd 100644
--- a/package/firewall/files/lib/core_init.sh
+++ b/package/firewall/files/lib/core_init.sh
@@ -271,8 +271,10 @@ fw_load_notrack_zone() {
fw_load_include() {
local name="$1"
- local path; config_get path ${name} path
- [ -e $path ] && . $path
+ local path
+ config_get path ${name} path
+
+ [ -e $path ] && ( . $path )
}