aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2021-07-14 17:42:28 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-07-17 13:27:03 +0200
commitb71767d8e047b06668ca8b7b7922f6df238ab659 (patch)
tree87915374bb00d4482bce6e654b1d4a0876c3d347
parent2e324c0a2c927461ab74f688fd878dce8fa52af2 (diff)
downloadupstream-b71767d8e047b06668ca8b7b7922f6df238ab659.tar.gz
upstream-b71767d8e047b06668ca8b7b7922f6df238ab659.tar.bz2
upstream-b71767d8e047b06668ca8b7b7922f6df238ab659.zip
kernel: bump 5.10 to 5.10.50
No deleted or manually refreshed patches. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch2
-rw-r--r--target/linux/ath79/patches-5.10/408-mtd-redboot_partition_scan.patch6
-rw-r--r--target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch2
-rw-r--r--target/linux/ath79/patches-5.10/920-mikrotik-rb4xx.patch2
-rw-r--r--target/linux/bcm63xx/patches-5.10/400-bcm963xx_flashmap.patch6
-rw-r--r--target/linux/generic/hack-5.10/221-module_exports.patch2
-rw-r--r--target/linux/generic/hack-5.10/661-use_fq_codel_by_default.patch2
-rw-r--r--target/linux/generic/pending-5.10/205-backtrace_module_info.patch4
-rw-r--r--target/linux/generic/pending-5.10/419-mtd-redboot-add-of_match_table-with-DT-binding.patch2
-rw-r--r--target/linux/generic/pending-5.10/420-mtd-redboot_space.patch2
-rw-r--r--target/linux/generic/pending-5.10/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch4
-rw-r--r--target/linux/mediatek/patches-5.10/410-bt-mtk-serial-fix.patch2
-rw-r--r--target/linux/mediatek/patches-5.10/800-ubnt-ledbar-driver.patch2
14 files changed, 21 insertions, 21 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 0af8d05fd1..2948f7b5e8 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
endif
LINUX_VERSION-5.4 = .132
-LINUX_VERSION-5.10 = .49
+LINUX_VERSION-5.10 = .50
LINUX_KERNEL_HASH-5.4.132 = 8466adbfb3579e751ede683496df7bb20f258b5f882250f3dd82be63736d00ef
-LINUX_KERNEL_HASH-5.10.49 = b0d16de7e79c272b01996ad8ff8bdf3a6a011bc0c94049baccf69f05dde3025e
+LINUX_KERNEL_HASH-5.10.50 = 8bda327a7d95acfff8f87fb6ef4223e3194fa22195f5551249a9aa3393bfb436
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch b/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
index a023d4c644..68b8310365 100644
--- a/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
+++ b/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
@@ -13,7 +13,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -928,6 +928,17 @@ config LEDS_ACER_A500
+@@ -929,6 +929,17 @@ config LEDS_ACER_A500
This option enables support for the Power Button LED of
Acer Iconia Tab A500.
diff --git a/target/linux/ath79/patches-5.10/408-mtd-redboot_partition_scan.patch b/target/linux/ath79/patches-5.10/408-mtd-redboot_partition_scan.patch
index 8f3ee32f57..e5b06e14a5 100644
--- a/target/linux/ath79/patches-5.10/408-mtd-redboot_partition_scan.patch
+++ b/target/linux/ath79/patches-5.10/408-mtd-redboot_partition_scan.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/parsers/redboot.c
+++ b/drivers/mtd/parsers/redboot.c
-@@ -85,12 +85,18 @@ static int parse_redboot_partitions(stru
+@@ -90,12 +90,18 @@ static int parse_redboot_partitions(stru
parse_redboot_of(master);
@@ -19,7 +19,7 @@
return -EIO;
}
offset -= master->erasesize;
-@@ -103,10 +109,6 @@ static int parse_redboot_partitions(stru
+@@ -108,10 +114,6 @@ static int parse_redboot_partitions(stru
goto nogood;
}
}
@@ -30,7 +30,7 @@
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
master->name, offset);
-@@ -179,6 +181,11 @@ static int parse_redboot_partitions(stru
+@@ -184,6 +186,11 @@ static int parse_redboot_partitions(stru
}
if (i == numslots) {
/* Didn't find it */
diff --git a/target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch b/target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
index c1cb0dae66..b9290dee1c 100644
--- a/target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
+++ b/target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
@@ -267,7 +267,7 @@
case IPV6_2292HOPOPTS:
--- a/net/ipv6/exthdrs.c
+++ b/net/ipv6/exthdrs.c
-@@ -949,7 +949,7 @@ static bool ipv6_hop_jumbo(struct sk_buf
+@@ -948,7 +948,7 @@ static bool ipv6_hop_jumbo(struct sk_buf
goto drop;
}
diff --git a/target/linux/ath79/patches-5.10/920-mikrotik-rb4xx.patch b/target/linux/ath79/patches-5.10/920-mikrotik-rb4xx.patch
index 01d623ab87..7c3c91817f 100644
--- a/target/linux/ath79/patches-5.10/920-mikrotik-rb4xx.patch
+++ b/target/linux/ath79/patches-5.10/920-mikrotik-rb4xx.patch
@@ -1,6 +1,6 @@
--- a/drivers/mfd/Kconfig
+++ b/drivers/mfd/Kconfig
-@@ -2141,6 +2141,14 @@ config RAVE_SP_CORE
+@@ -2142,6 +2142,14 @@ config RAVE_SP_CORE
Select this to get support for the Supervisory Processor
device found on several devices in RAVE line of hardware.
diff --git a/target/linux/bcm63xx/patches-5.10/400-bcm963xx_flashmap.patch b/target/linux/bcm63xx/patches-5.10/400-bcm963xx_flashmap.patch
index f57950b44a..5a9532c321 100644
--- a/target/linux/bcm63xx/patches-5.10/400-bcm963xx_flashmap.patch
+++ b/target/linux/bcm63xx/patches-5.10/400-bcm963xx_flashmap.patch
@@ -23,7 +23,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
.width = 2,
--- a/drivers/mtd/parsers/redboot.c
+++ b/drivers/mtd/parsers/redboot.c
-@@ -79,6 +79,7 @@ static int parse_redboot_partitions(stru
+@@ -84,6 +84,7 @@ static int parse_redboot_partitions(stru
int nulllen = 0;
int numslots;
unsigned long offset;
@@ -31,7 +31,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
static char nullstring[] = "unallocated";
#endif
-@@ -185,6 +186,16 @@ static int parse_redboot_partitions(stru
+@@ -190,6 +191,16 @@ static int parse_redboot_partitions(stru
goto out;
}
@@ -48,7 +48,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
for (i = 0; i < numslots; i++) {
struct fis_list *new_fl, **prev;
-@@ -205,10 +216,10 @@ static int parse_redboot_partitions(stru
+@@ -210,10 +221,10 @@ static int parse_redboot_partitions(stru
goto out;
}
new_fl->img = &buf[i];
diff --git a/target/linux/generic/hack-5.10/221-module_exports.patch b/target/linux/generic/hack-5.10/221-module_exports.patch
index e6854138e7..2fcb2d9809 100644
--- a/target/linux/generic/hack-5.10/221-module_exports.patch
+++ b/target/linux/generic/hack-5.10/221-module_exports.patch
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
"__kstrtabns_" #sym ": \n" \
--- a/scripts/Makefile.build
+++ b/scripts/Makefile.build
-@@ -366,7 +366,7 @@ targets += $(lib-y) $(always-y) $(MAKECM
+@@ -367,7 +367,7 @@ targets += $(lib-y) $(always-y) $(MAKECM
# Linker scripts preprocessor (.lds.S -> .lds)
# ---------------------------------------------------------------------------
quiet_cmd_cpp_lds_S = LDS $@
diff --git a/target/linux/generic/hack-5.10/661-use_fq_codel_by_default.patch b/target/linux/generic/hack-5.10/661-use_fq_codel_by_default.patch
index 863738e2ef..33c8c55ab6 100644
--- a/target/linux/generic/hack-5.10/661-use_fq_codel_by_default.patch
+++ b/target/linux/generic/hack-5.10/661-use_fq_codel_by_default.patch
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/include/net/sch_generic.h
+++ b/include/net/sch_generic.h
-@@ -611,12 +611,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
+@@ -623,12 +623,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
extern struct Qdisc_ops pfifo_fast_ops;
extern struct Qdisc_ops mq_qdisc_ops;
extern struct Qdisc_ops noqueue_qdisc_ops;
diff --git a/target/linux/generic/pending-5.10/205-backtrace_module_info.patch b/target/linux/generic/pending-5.10/205-backtrace_module_info.patch
index 5953214757..f46877f254 100644
--- a/target/linux/generic/pending-5.10/205-backtrace_module_info.patch
+++ b/target/linux/generic/pending-5.10/205-backtrace_module_info.patch
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/lib/vsprintf.c
+++ b/lib/vsprintf.c
-@@ -957,8 +957,10 @@ char *symbol_string(char *buf, char *end
+@@ -983,8 +983,10 @@ char *symbol_string(char *buf, char *end
struct printf_spec spec, const char *fmt)
{
unsigned long value;
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#endif
if (fmt[1] == 'R')
-@@ -975,8 +977,14 @@ char *symbol_string(char *buf, char *end
+@@ -1001,8 +1003,14 @@ char *symbol_string(char *buf, char *end
return string_nocheck(buf, end, sym, spec);
#else
diff --git a/target/linux/generic/pending-5.10/419-mtd-redboot-add-of_match_table-with-DT-binding.patch b/target/linux/generic/pending-5.10/419-mtd-redboot-add-of_match_table-with-DT-binding.patch
index 8358a307cd..7692f484ae 100644
--- a/target/linux/generic/pending-5.10/419-mtd-redboot-add-of_match_table-with-DT-binding.patch
+++ b/target/linux/generic/pending-5.10/419-mtd-redboot-add-of_match_table-with-DT-binding.patch
@@ -12,7 +12,7 @@ Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
--- a/drivers/mtd/parsers/redboot.c
+++ b/drivers/mtd/parsers/redboot.c
-@@ -300,6 +300,7 @@ static int parse_redboot_partitions(stru
+@@ -305,6 +305,7 @@ static int parse_redboot_partitions(stru
static const struct of_device_id mtd_parser_redboot_of_match_table[] = {
{ .compatible = "redboot-fis" },
diff --git a/target/linux/generic/pending-5.10/420-mtd-redboot_space.patch b/target/linux/generic/pending-5.10/420-mtd-redboot_space.patch
index a2cf838989..a3cd4ecf1f 100644
--- a/target/linux/generic/pending-5.10/420-mtd-redboot_space.patch
+++ b/target/linux/generic/pending-5.10/420-mtd-redboot_space.patch
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/drivers/mtd/parsers/redboot.c
+++ b/drivers/mtd/parsers/redboot.c
-@@ -274,14 +274,21 @@ static int parse_redboot_partitions(stru
+@@ -279,14 +279,21 @@ static int parse_redboot_partitions(stru
#endif
names += strlen(names)+1;
diff --git a/target/linux/generic/pending-5.10/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch b/target/linux/generic/pending-5.10/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
index ddb94fbe55..89eb7d61b3 100644
--- a/target/linux/generic/pending-5.10/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
+++ b/target/linux/generic/pending-5.10/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
@@ -311,7 +311,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
/**
* ip6_tnl_addr_conflict - compare packet addresses to tunnel's own
* @t: the outgoing tunnel device
-@@ -1306,6 +1454,7 @@ ipxip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1304,6 +1452,7 @@ ipxip6_tnl_xmit(struct sk_buff *skb, str
u8 protocol)
{
struct ip6_tnl *t = netdev_priv(dev);
@@ -319,7 +319,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
struct ipv6hdr *ipv6h;
const struct iphdr *iph;
int encap_limit = -1;
-@@ -1405,6 +1554,18 @@ ipxip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1403,6 +1552,18 @@ ipxip6_tnl_xmit(struct sk_buff *skb, str
fl6.flowi6_uid = sock_net_uid(dev_net(dev), NULL);
dsfield = INET_ECN_encapsulate(dsfield, orig_dsfield);
diff --git a/target/linux/mediatek/patches-5.10/410-bt-mtk-serial-fix.patch b/target/linux/mediatek/patches-5.10/410-bt-mtk-serial-fix.patch
index 8dc680d180..381eaab5e2 100644
--- a/target/linux/mediatek/patches-5.10/410-bt-mtk-serial-fix.patch
+++ b/target/linux/mediatek/patches-5.10/410-bt-mtk-serial-fix.patch
@@ -19,7 +19,7 @@
},
[PORT_NPCM] = {
.name = "Nuvoton 16550",
-@@ -2699,6 +2699,11 @@ serial8250_do_set_termios(struct uart_po
+@@ -2712,6 +2712,11 @@ serial8250_do_set_termios(struct uart_po
unsigned long flags;
unsigned int baud, quot, frac = 0;
diff --git a/target/linux/mediatek/patches-5.10/800-ubnt-ledbar-driver.patch b/target/linux/mediatek/patches-5.10/800-ubnt-ledbar-driver.patch
index 013391e1d9..92264eedf9 100644
--- a/target/linux/mediatek/patches-5.10/800-ubnt-ledbar-driver.patch
+++ b/target/linux/mediatek/patches-5.10/800-ubnt-ledbar-driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -928,6 +928,16 @@ config LEDS_ACER_A500
+@@ -929,6 +929,16 @@ config LEDS_ACER_A500
This option enables support for the Power Button LED of
Acer Iconia Tab A500.