aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilip Moc <lede@moc6.cz>2020-11-24 22:15:26 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-11-25 13:23:06 +0100
commitb641eb6ecfbfc2c6a488483332d4b5a6ee4c736c (patch)
treeb902644d19bed7d697333a10f5332baffbe80b3c
parentb31aaa0580c94bc69e1891932f41ff10e5cb2da2 (diff)
downloadupstream-b641eb6ecfbfc2c6a488483332d4b5a6ee4c736c.tar.gz
upstream-b641eb6ecfbfc2c6a488483332d4b5a6ee4c736c.tar.bz2
upstream-b641eb6ecfbfc2c6a488483332d4b5a6ee4c736c.zip
ramips: add support for TP-Link MR6400 v5
TL-MR6400v5 is very similar to TL-MR6400v4. Main differences are: - smaller form factor - different LED GPIOs - different switch connections You can flash via tftp recovery: - serve tftp-recovery image as /tp_recovery.bin on 192.168.0.225/24 - connect to any ethernet port - power on the device while holding the reset button - wait at least 8 seconds before releasing reset button Flashing via OEM web interface does not work. LTE module does not support DHCP so it must be configured via QMI. Hardware Specification (v5.0 EU): - SoC: MT7628NN - Flash: Winbond W25Q64JVS (8MiB) - RAM: ESMT M14D5121632A (64MiB) - Wireless: SoC platform only (2.4GHz b/g/n, 2x internal antenna) - Ethernet: 1NIC (4x100M) - WWAN: TP-LINK LTE MODULE (2x external detachable antenna) - Power: DC 9V 0.85A Signed-off-by: Filip Moc <lede@moc6.cz>
-rw-r--r--target/linux/ramips/dts/mt7628an_tplink_tl-mr6400-v5.dts99
-rw-r--r--target/linux/ramips/image/mt76x8.mk16
-rwxr-xr-xtarget/linux/ramips/mt76x8/base-files/etc/board.d/01_leds4
-rwxr-xr-xtarget/linux/ramips/mt76x8/base-files/etc/board.d/02_network4
4 files changed, 123 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7628an_tplink_tl-mr6400-v5.dts b/target/linux/ramips/dts/mt7628an_tplink_tl-mr6400-v5.dts
new file mode 100644
index 0000000000..71e9694dde
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_tplink_tl-mr6400-v5.dts
@@ -0,0 +1,99 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an_tplink_8m.dtsi"
+
+/ {
+ compatible = "tplink,tl-mr6400-v5", "mediatek,mt7628an-soc";
+ model = "TP-Link TL-MR6400 v5";
+
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ rfkill {
+ label = "rfkill";
+ gpios = <&gpio 46 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RFKILL>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ wlan {
+ label = "white:wlan";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ lan {
+ label = "white:lan";
+ gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
+ };
+
+ led_power: power {
+ label = "white:power";
+ gpios = <&gpio 39 GPIO_ACTIVE_LOW>;
+ };
+
+ wan {
+ label = "white:wan";
+ gpios = <&gpio 40 GPIO_ACTIVE_LOW>;
+ };
+
+ signal1 {
+ label = "white:signal1";
+ gpios = <&gpio 41 GPIO_ACTIVE_LOW>;
+ };
+
+ signal2 {
+ label = "white:signal2";
+ gpios = <&gpio 42 GPIO_ACTIVE_LOW>;
+ };
+
+ signal3 {
+ label = "white:signal3";
+ gpios = <&gpio 43 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ohci {
+ status = "okay";
+};
+
+&state_default {
+ gpio {
+ groups = "i2c", "p0led_an", "p1led_an", "p2led_an", "p3led_an", "p4led_an", "uart1", "wdt";
+ function = "gpio";
+ };
+};
+
+&esw {
+ mediatek,portmap = <0x37>;
+ mediatek,portdisable = <0x30>;
+};
+
+&wmac {
+ mtd-mac-address = <&factory 0x1f100>;
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x1f100>;
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 30c41420aa..72539f7a14 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -498,6 +498,22 @@ define Device/tplink_tl-mr6400-v4
endef
TARGET_DEVICES += tplink_tl-mr6400-v4
+define Device/tplink_tl-mr6400-v5
+ $(Device/tplink-v2)
+ IMAGE_SIZE := 7808k
+ DEVICE_MODEL := TL-MR6400
+ DEVICE_VARIANT := v5
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0x64000005
+ TPLINK_HWREV := 0x5
+ TPLINK_HWREVADD := 0x5
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport \
+ kmod-usb-serial kmod-usb-serial-option kmod-usb-net-qmi-wwan uqmi
+ IMAGES := sysupgrade.bin tftp-recovery.bin
+ IMAGE/tftp-recovery.bin := pad-extra 128k | $$(IMAGE/factory.bin)
+endef
+TARGET_DEVICES += tplink_tl-mr6400-v5
+
define Device/tplink_tl-wa801nd-v5
$(Device/tplink-v2)
IMAGE_SIZE := 7808k
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds b/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
index 4ed38bf5f2..31bd9e05b1 100755
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
@@ -79,6 +79,10 @@ tplink,tl-mr6400-v4)
ucidef_set_led_switch "lan" "lan" "white:lan" "switch0" "0x0e"
ucidef_set_led_switch "wan" "wan" "white:wan" "switch0" "0x10"
;;
+tplink,tl-mr6400-v5)
+ ucidef_set_led_switch "lan" "lan" "white:lan" "switch0" "0x07"
+ ucidef_set_led_switch "wan" "wan" "white:wan" "switch0" "0x08"
+ ;;
tplink,tl-wr841n-v13)
ucidef_set_led_wlan "wlan2g" "wlan2g" "green:wlan" "phy0tpt"
ucidef_set_led_switch "lan1" "lan1" "green:lan1" "switch0" "0x2"
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
index a7e978a2e2..f4e3fcacb5 100755
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
@@ -116,6 +116,10 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"1:lan" "2:lan" "3:lan" "4:wan" "6@eth0"
;;
+ tplink,tl-mr6400-v5)
+ ucidef_add_switch "switch0" \
+ "0:lan" "1:lan" "2:lan" "3:wan" "6@eth0"
+ ;;
tplink,tl-wr902ac-v3)
ucidef_add_switch "switch0" \
"4:lan" "6@eth0"