aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-03-15 21:41:50 +0000
committerNicolas Thill <nico@openwrt.org>2006-03-15 21:41:50 +0000
commitb3a49ec135b90fa5796e14a8af681df4921d08c4 (patch)
treedab93a8b43e2490abcc90ffc298b1fa1f73dc5f1
parent5375f6a072deb0f877d5b95fe317eee83f78efed (diff)
downloadupstream-b3a49ec135b90fa5796e14a8af681df4921d08c4.tar.gz
upstream-b3a49ec135b90fa5796e14a8af681df4921d08c4.tar.bz2
upstream-b3a49ec135b90fa5796e14a8af681df4921d08c4.zip
add a patch to use cppflags when compiling and ldflags when linking, it should prevent libtool from linking against host libraries.
SVN-Revision: 3382
-rw-r--r--openwrt/package/pcre/patches/100-honor_cppflags_ldflags.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/openwrt/package/pcre/patches/100-honor_cppflags_ldflags.patch b/openwrt/package/pcre/patches/100-honor_cppflags_ldflags.patch
new file mode 100644
index 0000000000..2d14b89499
--- /dev/null
+++ b/openwrt/package/pcre/patches/100-honor_cppflags_ldflags.patch
@@ -0,0 +1,24 @@
+diff -ruN pcre-5.0-old/Makefile.in pcre-5.0-new/Makefile.in
+--- pcre-5.0-old/Makefile.in 2004-09-13 16:20:00.000000000 +0200
++++ pcre-5.0-new/Makefile.in 2006-03-15 08:28:12.000000000 +0100
+@@ -63,6 +63,7 @@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
+ CPPFLAGS = @CPPFLAGS@
++LDFLAGS = @LDFLAGS@
+
+ CC_FOR_BUILD = @CC_FOR_BUILD@
+ CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
+@@ -84,10 +85,10 @@
+ # to do one or the other or both by ./configure.
+
+ LIBTOOL = @LIBTOOL@
+-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) -I. -I$(top_srcdir) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
++LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) -I. -I$(top_srcdir) $(CPPFLAGS) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
+ @ON_WINDOWS@LINK = $(CC) $(CFLAGS) -I. -I$(top_srcdir) -L.libs
+ @NOT_ON_WINDOWS@LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir)
+-LINKLIB = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir)
++LINKLIB = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir) $(LDFLAGS)
+ LINK_FOR_BUILD = $(LIBTOOL) --mode=link $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) -I. -I$(top_srcdir)
+
+ # These are the version numbers for the shared libraries