aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-02-21 14:58:20 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-25 13:45:18 +0100
commitb2d7cdaea9fdbd4a05c90c252ef0abdeaaea4381 (patch)
treed231f870b886c83e8940a03758ae36d14f0d0fba
parent6a7cde15000832ce0164dc27d85822b2e2dd9fe6 (diff)
downloadupstream-b2d7cdaea9fdbd4a05c90c252ef0abdeaaea4381.tar.gz
upstream-b2d7cdaea9fdbd4a05c90c252ef0abdeaaea4381.tar.bz2
upstream-b2d7cdaea9fdbd4a05c90c252ef0abdeaaea4381.zip
toolchain: remove references to $(LIBC)/utils subtarget
The utils subtarget was used for uClibc and eglibc which are both obsolete and replaced in Openwrt by mainline musl and glibc, which do not have a utils Makefile target. Ref: 5d19a38d8 ("toolchain: sync eglibc headers/build split with uclibc changes") Fixes: 63fb17520 ("toolchain: remove uClibc-ng") Suggested-by: Andre Heider <a.heider@gmail.com> Signed-off-by: Michael Pratt <mcpratt@pm.me>
-rw-r--r--toolchain/Makefile3
1 files changed, 0 insertions, 3 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 60e3507250..c0046293c9 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -21,8 +21,6 @@
# build & install the final libc
# 7) toolchain/gcc/final/compile
# build & install the final gcc
-# 8) toolchain/libc/utils/compile
-# build & install libc utilities
#
# For musl, steps 2 and 4 are skipped, and step 3 is done after 5
@@ -46,7 +44,6 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/compile $(curdir)/kernel-headers/compile
$(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile
- $(curdir)/$(LIBC)/utils/compile:=$(curdir)/gcc/final/compile
endif
ifndef DUMP_TARGET_DB