aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2023-06-21 02:30:20 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-06-25 12:34:47 +0200
commitb1b829ad6a71f32c0f8a669db53264cf5b1f259b (patch)
tree572231a4abdc7990287ce260a5acfba9f841a18e
parentfca03ea4584e08e53e766d71f12c840d62f3e5ec (diff)
downloadupstream-b1b829ad6a71f32c0f8a669db53264cf5b1f259b.tar.gz
upstream-b1b829ad6a71f32c0f8a669db53264cf5b1f259b.tar.bz2
upstream-b1b829ad6a71f32c0f8a669db53264cf5b1f259b.zip
ipq40xx: meraki-mr33, meraki-mr74: disable image generation
After migrating to kernel 5.15, upgrading causes the units to become soft-bricked, hanging forever at the kernel startup. Kernel size limitation of 4000000 bytes is suspected here, but this is not fully confirmed. Disable the images to protect users from inadvertent bricking of units, because recovery of those is painful with Cisco's U-boot, until the root cause is found and fixed. Signed-off-by: Lech Perczak <lech.perczak@gmail.com> (cherry picked from commit 9d64cc068fbb15d9e6498c1eba79851823b2f4f5)
-rw-r--r--target/linux/ipq40xx/image/generic.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 59d4f082ff..671fca1682 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -764,6 +764,7 @@ define Device/meraki_mr33
BLOCKSIZE := 128k
PAGESIZE := 2048
DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
+ DEFAULT := n
endef
TARGET_DEVICES += meraki_mr33
@@ -776,6 +777,7 @@ define Device/meraki_mr74
PAGESIZE := 2048
DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
DEVICE_DTS_CONFIG := config@3
+ DEFAULT := n
endef
TARGET_DEVICES += meraki_mr74