aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-20 01:18:44 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-20 01:18:44 +0100
commitb085e0586faf4da4b2c296ddf31885dd781bd85c (patch)
tree1ea24049ae9dacb98cabe7d7653ead7f32f3d67e
parent58e71e322bc0e0edd08157075e9022c15ae33ec5 (diff)
downloadupstream-b085e0586faf4da4b2c296ddf31885dd781bd85c.tar.gz
upstream-b085e0586faf4da4b2c296ddf31885dd781bd85c.tar.bz2
upstream-b085e0586faf4da4b2c296ddf31885dd781bd85c.zip
sunxi: rename SUNXI_SOC to SOC
This replaces SUNXI_SOC by the newly introduced common SOC device variable. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--target/linux/sunxi/image/Makefile5
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk12
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk46
-rw-r--r--target/linux/sunxi/image/cortex-a8.mk12
4 files changed, 37 insertions, 38 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 929f4c70f9..888c1c5a9b 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -32,15 +32,14 @@ endef
# why \x00\x00\x00\x00 for zImage-initramfs
define Device/Default
PROFILES := Default
- DEVICE_VARS := SUNXI_SOC SUNXI_DTS SUNXI_DTS_DIR SUNXI_UBOOT
+ DEVICE_VARS := SUNXI_DTS SUNXI_DTS_DIR SUNXI_UBOOT
KERNEL_NAME := zImage
KERNEL := kernel-bin | uImage none
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
- SUNXI_SOC :=
SUNXI_DTS_DIR :=
- SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SUNXI_SOC)-$(lastword $(subst _, ,$(1)))
+ SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
endef
include cortex-a7.mk
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index b0d087b9b1..ac82138938 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -12,7 +12,7 @@ define Device/friendlyarm_nanopi-neo-plus2
DEVICE_MODEL := NanoPi NEO Plus2
SUPPORTED_DEVICES:=nanopi-neo-plus2
SUNXI_DTS_DIR := allwinner/
- SUNXI_SOC := sun50i-h5
+ SOC := sun50i-h5
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
@@ -24,7 +24,7 @@ define Device/friendlyarm_nanopi-neo2
DEVICE_MODEL := NanoPi NEO2
SUPPORTED_DEVICES:=nanopi-neo2
SUNXI_DTS_DIR := allwinner/
- SUNXI_SOC := sun50i-h5
+ SOC := sun50i-h5
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
@@ -35,7 +35,7 @@ define Device/pine64_pine64-plus
DEVICE_VENDOR := Pine64
DEVICE_MODEL := Pine64+
SUNXI_DTS_DIR := allwinner/
- SUNXI_SOC := sun50i-a64
+ SOC := sun50i-a64
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
@@ -46,7 +46,7 @@ define Device/pine64_sopine-baseboard
DEVICE_VENDOR := Pine64
DEVICE_MODEL := SoPine
SUNXI_DTS_DIR := allwinner/
- SUNXI_SOC := sun50i-a64
+ SOC := sun50i-a64
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
@@ -58,7 +58,7 @@ define Device/xunlong_orangepi-zero-plus
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi Zero Plus
SUNXI_DTS_DIR := allwinner/
- SUNXI_SOC := sun50i-h5
+ SOC := sun50i-h5
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
@@ -69,7 +69,7 @@ define Device/xunlong_orangepi-pc2
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi PC 2
SUNXI_DTS_DIR := allwinner/
- SUNXI_SOC := sun50i-h5
+ SOC := sun50i-h5
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index 83b313a378..3dad8b19b4 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -12,7 +12,7 @@ define Device/olimex_a20-olinuxino-lime
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A20-OLinuXino-LIME
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi
- SUNXI_SOC := sun7i
+ SOC := sun7i
endef
TARGET_DEVICES += olimex_a20-olinuxino-lime
@@ -22,7 +22,7 @@ define Device/olimex_a20-olinuxino-lime2
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A20-OLinuXino-LIME2
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
- SUNXI_SOC := sun7i
+ SOC := sun7i
endef
TARGET_DEVICES += olimex_a20-olinuxino-lime2
@@ -33,7 +33,7 @@ define Device/olimex_a20-olinuxino-lime2-emmc
DEVICE_MODEL := A20-OLinuXino-LIME2
DEVICE_VARIANT := eMMC
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
- SUNXI_SOC := sun7i
+ SOC := sun7i
endef
TARGET_DEVICES += olimex_a20-olinuxino-lime2-emmc
@@ -43,7 +43,7 @@ define Device/olimex_a20-olinuxino-micro
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A20-OLinuXino-MICRO
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SUNXI_SOC := sun7i
+ SOC := sun7i
endef
TARGET_DEVICES += olimex_a20-olinuxino-micro
@@ -53,7 +53,7 @@ define Device/lemaker_bananapi
DEVICE_VENDOR := LeMaker
DEVICE_MODEL := Banana Pi
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi
- SUNXI_SOC := sun7i-a20
+ SOC := sun7i-a20
endef
TARGET_DEVICES += lemaker_bananapi
@@ -63,7 +63,7 @@ define Device/lemaker_bananapro
DEVICE_VENDOR := LeMaker
DEVICE_MODEL := Banana Pro
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi kmod-brcmfmac
- SUNXI_SOC := sun7i-a20
+ SOC := sun7i-a20
endef
TARGET_DEVICES += lemaker_bananapro
@@ -73,7 +73,7 @@ define Device/cubietech_cubieboard2
DEVICE_VENDOR := Cubietech
DEVICE_MODEL := Cubieboard2
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SUNXI_SOC := sun7i-a20
+ SOC := sun7i-a20
endef
TARGET_DEVICES += cubietech_cubieboard2
@@ -83,7 +83,7 @@ define Device/cubietech_cubietruck
DEVICE_VENDOR := Cubietech
DEVICE_MODEL := Cubietruck
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-brcmfmac
- SUNXI_SOC := sun7i-a20
+ SOC := sun7i-a20
endef
TARGET_DEVICES += cubietech_cubietruck
@@ -93,7 +93,7 @@ define Device/lamobo_lamobo-r1
DEVICE_VENDOR := Lamobo
DEVICE_MODEL := Lamobo R1
DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtl8192cu swconfig wpad-basic
- SUNXI_SOC := sun7i-a20
+ SOC := sun7i-a20
endef
TARGET_DEVICES += lamobo_lamobo-r1
@@ -103,7 +103,7 @@ define Device/mele_m9
DEVICE_VENDOR := Mele
DEVICE_MODEL := M9
DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
- SUNXI_SOC := sun6i-a31
+ SOC := sun6i-a31
endef
TARGET_DEVICES += mele_m9
@@ -113,7 +113,7 @@ define Device/xunlong_orangepi-zero
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi Zero
DEVICE_PACKAGES:=kmod-rtc-sunxi
- SUNXI_SOC := sun8i-h2-plus
+ SOC := sun8i-h2-plus
endef
TARGET_DEVICES += xunlong_orangepi-zero
@@ -123,7 +123,7 @@ define Device/xunlong_orangepi-r1
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi R1
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152
- SUNXI_SOC := sun8i-h2-plus
+ SOC := sun8i-h2-plus
endef
TARGET_DEVICES += xunlong_orangepi-r1
@@ -134,7 +134,7 @@ define Device/sinovoip_bananapi-m2-plus
DEVICE_PACKAGES:=kmod-rtc-sunxi \
kmod-leds-gpio kmod-ledtrig-heartbeat \
kmod-brcmfmac brcmfmac-firmware-43430a0-sdio wpad-basic
- SUNXI_SOC := sun8i-h3
+ SOC := sun8i-h3
endef
TARGET_DEVICES += sinovoip_bananapi-m2-plus
@@ -145,7 +145,7 @@ define Device/friendlyarm_nanopi-m1-plus
DEVICE_PACKAGES:=kmod-rtc-sunxi \
kmod-leds-gpio kmod-ledtrig-heartbeat \
kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
- SUNXI_SOC := sun8i-h3
+ SOC := sun8i-h3
endef
TARGET_DEVICES += friendlyarm_nanopi-m1-plus
@@ -154,7 +154,7 @@ TARGET_DEVICES += friendlyarm_nanopi-m1-plus
define Device/friendlyarm_nanopi-neo
DEVICE_VENDOR := FriendlyARM
DEVICE_MODEL := NanoPi NEO
- SUNXI_SOC := sun8i-h3
+ SOC := sun8i-h3
endef
TARGET_DEVICES += friendlyarm_nanopi-neo
@@ -166,7 +166,7 @@ define Device/friendlyarm_nanopi-neo-air
DEVICE_PACKAGES := kmod-rtc-sunxi \
kmod-leds-gpio kmod-ledtrig-heartbeat \
kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
- SUNXI_SOC := sun8i-h3
+ SOC := sun8i-h3
endef
TARGET_DEVICES += friendlyarm_nanopi-neo-air
@@ -176,7 +176,7 @@ define Device/xunlong_orangepi-one
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi One
DEVICE_PACKAGES:=kmod-rtc-sunxi
- SUNXI_SOC := sun8i-h3
+ SOC := sun8i-h3
endef
TARGET_DEVICES += xunlong_orangepi-one
@@ -186,7 +186,7 @@ define Device/xunlong_orangepi-pc
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi PC
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
- SUNXI_SOC := sun8i-h3
+ SOC := sun8i-h3
endef
TARGET_DEVICES += xunlong_orangepi-pc
@@ -196,7 +196,7 @@ define Device/xunlong_orangepi-pc-plus
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi PC Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
- SUNXI_SOC := sun8i-h3
+ SOC := sun8i-h3
endef
TARGET_DEVICES += xunlong_orangepi-pc-plus
@@ -206,7 +206,7 @@ define Device/xunlong_orangepi-plus
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi
- SUNXI_SOC := sun8i-h3
+ SOC := sun8i-h3
endef
TARGET_DEVICES += xunlong_orangepi-plus
@@ -215,7 +215,7 @@ define Device/xunlong_orangepi-2
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi 2
DEVICE_PACKAGES:=kmod-rtc-sunxi
- SUNXI_SOC := sun8i-h3
+ SOC := sun8i-h3
endef
TARGET_DEVICES += xunlong_orangepi-2
@@ -225,7 +225,7 @@ define Device/linksprite_pcduino3
DEVICE_VENDOR := LinkSprite
DEVICE_MODEL := pcDuino3
DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi kmod-rtl8xxxu rtl8188eu-firmware
- SUNXI_SOC := sun7i-a20
+ SOC := sun7i-a20
endef
TARGET_DEVICES += linksprite_pcduino3
@@ -234,7 +234,7 @@ define Device/lemaker_bananapi-m2-ultra
DEVICE_VENDOR := LeMaker
DEVICE_MODEL := Banana Pi M2 Ultra
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi
- SUNXI_SOC := sun8i-r40
+ SOC := sun8i-r40
endef
TARGET_DEVICES += lemaker_bananapi-m2-ultra
diff --git a/target/linux/sunxi/image/cortex-a8.mk b/target/linux/sunxi/image/cortex-a8.mk
index d6b5a46a22..fdebfa716c 100644
--- a/target/linux/sunxi/image/cortex-a8.mk
+++ b/target/linux/sunxi/image/cortex-a8.mk
@@ -11,7 +11,7 @@ define Device/olimex_a10-olinuxino-lime
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A10-OLinuXino-LIME
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SUNXI_SOC := sun4i
+ SOC := sun4i
endef
TARGET_DEVICES += olimex_a10-olinuxino-lime
@@ -22,7 +22,7 @@ define Device/olimex_a13-olimex-som
DEVICE_MODEL := A13-SOM
DEVICE_PACKAGES:=kmod-rtl8192cu
SUPPORTED_DEVICES:=olimex,a13-olinuxino
- SUNXI_SOC := sun5i-a13
+ SOC := sun5i-a13
SUNXI_DTS := sun5i-a13-olinuxino
endef
@@ -33,7 +33,7 @@ define Device/olimex_a13-olinuxino
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A13-OLinuXino
DEVICE_PACKAGES:=kmod-rtl8192cu
- SUNXI_SOC := sun5i
+ SOC := sun5i
endef
TARGET_DEVICES += olimex_a13-olinuxino
@@ -43,7 +43,7 @@ define Device/cubietech_a10-cubieboard
DEVICE_VENDOR := Cubietech
DEVICE_MODEL := Cubieboard
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SUNXI_SOC := sun4i
+ SOC := sun4i
endef
TARGET_DEVICES += cubietech_a10-cubieboard
@@ -53,7 +53,7 @@ define Device/linksprite_a10-pcduino
DEVICE_VENDOR := LinkSprite
DEVICE_MODEL := pcDuino
DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
- SUNXI_SOC := sun4i
+ SOC := sun4i
endef
TARGET_DEVICES += linksprite_a10-pcduino
@@ -63,7 +63,7 @@ define Device/marsboard_a10-marsboard
DEVICE_VENDOR := HAOYU Electronics
DEVICE_MODEL := MarsBoard A10
DEVICE_PACKAGES:=mod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi sound-soc-sunxi
- SUNXI_SOC := sun4i
+ SOC := sun4i
endef
TARGET_DEVICES += marsboard_a10-marsboard