aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-04-01 15:59:13 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-04-01 15:59:13 +0000
commitafd37fbbc606aa804be99e5be2044d0b95e4f127 (patch)
treecf63437262cda8eb74b3805d1d3829c3f1183351
parent9f2d6b0c73f06c1e5d79bcbb06350254e134a7f3 (diff)
downloadupstream-afd37fbbc606aa804be99e5be2044d0b95e4f127.tar.gz
upstream-afd37fbbc606aa804be99e5be2044d0b95e4f127.tar.bz2
upstream-afd37fbbc606aa804be99e5be2044d0b95e4f127.zip
small compile fix for gcc 3.4.3
SVN-Revision: 503
-rw-r--r--openwrt/package/ebtables/Makefile1
-rw-r--r--openwrt/package/ebtables/patches/gcc3.4-ebtables_c.patch10
2 files changed, 11 insertions, 0 deletions
diff --git a/openwrt/package/ebtables/Makefile b/openwrt/package/ebtables/Makefile
index 3f0b467ba4..809caf3c0e 100644
--- a/openwrt/package/ebtables/Makefile
+++ b/openwrt/package/ebtables/Makefile
@@ -19,6 +19,7 @@ $(DL_DIR)/$(PKG_SOURCE):
$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ $(PATCH) $(PKG_BUILD_DIR) ./patches
touch $(PKG_BUILD_DIR)/.unpacked
$(PKG_BUILD_DIR)/ebtables: $(PKG_BUILD_DIR)/.unpacked
diff --git a/openwrt/package/ebtables/patches/gcc3.4-ebtables_c.patch b/openwrt/package/ebtables/patches/gcc3.4-ebtables_c.patch
new file mode 100644
index 0000000000..1973ea57f7
--- /dev/null
+++ b/openwrt/package/ebtables/patches/gcc3.4-ebtables_c.patch
@@ -0,0 +1,10 @@
+--- ebtables-v2.0.6/ebtables.c 2003-11-02 19:22:56.000000000 +0100
++++ ebtables-patch/ebtables.c 2005-03-29 08:03:09.734707134 +0200
+@@ -1171,6 +1171,7 @@
+ continue;
+ return i;
+ letscontinue:
++ {};
+ }
+ return -1;
+ }