aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-05-29 11:28:10 +0000
committerJohn Crispin <john@openwrt.org>2015-05-29 11:28:10 +0000
commitadbec3f1326210732cdfa3a456cee5fe669f540a (patch)
treef0d689ac35b0a1f7e117f825607594c35d7ecc8c
parent80a933af988bcefd80c4e73f7c47ae410588af3a (diff)
downloadupstream-adbec3f1326210732cdfa3a456cee5fe669f540a.tar.gz
upstream-adbec3f1326210732cdfa3a456cee5fe669f540a.tar.bz2
upstream-adbec3f1326210732cdfa3a456cee5fe669f540a.zip
ramips: fix imagebuilder
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 45820
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 422366c098..4ae9ca4f2b 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -62,7 +62,7 @@ endef
define Build/relocate-kernel
( \
- dd if=$(KDIR)/relocate/loader.bin bs=32 conv=sync && \
+ dd if=$(KDIR)/loader.bin bs=32 conv=sync && \
perl -e '@s = stat("$@"); print pack("V", @s[7])' && \
cat $@ \
) > $@.new
@@ -989,10 +989,12 @@ endef
endif
ifeq ($(SUBTARGET),mt7621)
-define Build/Compile
+define Image/Prepare
+#define Build/Compile
rm -rf $(KDIR)/relocate
$(CP) ../../generic/image/relocate $(KDIR)
$(MAKE) -C $(KDIR)/relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
+ $(CP) $(KDIR)/relocate/loader.bin $(KDIR)/loader.bin
endef
endif