aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason A. Donenfeld <Jason@zx2c4.com>2020-07-12 21:37:11 -0600
committerHans Dedecker <dedeckeh@gmail.com>2020-07-13 08:02:02 +0200
commitad81e2da0888a0c346c9ceeeaf0481386838f846 (patch)
tree0e4e10cd129c77fa59dd56eef721bb9810d0a514
parent8242c6de29951fbb549355770cd685ffe3ac9c54 (diff)
downloadupstream-ad81e2da0888a0c346c9ceeeaf0481386838f846.tar.gz
upstream-ad81e2da0888a0c346c9ceeeaf0481386838f846.tar.bz2
upstream-ad81e2da0888a0c346c9ceeeaf0481386838f846.zip
wireguard: bump to 1.0.20200712
This release brings parity with the commits Linus released a few hours ago into 5.8-rc5. * receive: account for napi_gro_receive never returning GRO_DROP The napi_gro_receive function no longer returns GRO_DROP ever, making handling GRO_DROP dead code. This commit removes that dead code. Further, it's not even clear that device drivers have any business in taking action after passing off received packets; that's arguably out of their hands. * device: implement header_ops->parse_protocol for AF_PACKET WireGuard uses skb->protocol to determine packet type, and bails out if it's not set or set to something it's not expecting. For AF_PACKET injection, we need to support its call chain of: packet_sendmsg -> packet_snd -> packet_parse_headers -> dev_parse_header_protocol -> parse_protocol Without a valid parse_protocol, this returns zero, and wireguard then rejects the skb. So, this wires up the ip_tunnel handler for layer 3 packets for that case. * queueing: make use of ip_tunnel_parse_protocol Now that wg_examine_packet_protocol has been added for general consumption as ip_tunnel_parse_protocol, it's possible to remove wg_examine_packet_protocol and simply use the new ip_tunnel_parse_protocol function directly. * compat: backport ip_tunnel_parse_protocol and ip_tunnel_header_ops These are required for moving wg_examine_packet_protocol out of wireguard and into upstream. Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
-rw-r--r--package/network/services/wireguard/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/wireguard/Makefile b/package/network/services/wireguard/Makefile
index b7adf27ec1..19aea4bb09 100644
--- a/package/network/services/wireguard/Makefile
+++ b/package/network/services/wireguard/Makefile
@@ -11,12 +11,12 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=wireguard
-PKG_VERSION:=1.0.20200623
+PKG_VERSION:=1.0.20200712
PKG_RELEASE:=1
PKG_SOURCE:=wireguard-linux-compat-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://git.zx2c4.com/wireguard-linux-compat/snapshot/
-PKG_HASH:=130937724515799edf05ff8216bc837df8acda879428f3a7f96a3287758f9445
+PKG_HASH:=e15b3d4eb2cf186920a6ed13685187d6b846e59eb383c291913628682965ac95
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING