aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-03-03 17:29:41 +0100
committerJo-Philipp Wich <jo@mein.io>2017-03-03 18:14:36 +0100
commita92d97790468ade42bc18b3d96dadc9dd6ac37b1 (patch)
tree7ff6359319a3440b83835fd842f196e1e8cc8a1c
parent4101020dfbc3538cd96251e957ae67a9ef7fad94 (diff)
downloadupstream-a92d97790468ade42bc18b3d96dadc9dd6ac37b1.tar.gz
upstream-a92d97790468ade42bc18b3d96dadc9dd6ac37b1.tar.bz2
upstream-a92d97790468ade42bc18b3d96dadc9dd6ac37b1.zip
kernel: fix kmod-tpm-tis packaging
The tmp-tis module depends on tpm_tis_core.ko, so package this file as well. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--package/kernel/linux/modules/other.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 3b2d2e9667..40869c6bb0 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -974,7 +974,9 @@ define KernelPackage/tpm-tis
TITLE:=TPM TIS 1.2 Interface / TPM 2.0 FIFO Interface
DEPENDS:= @TARGET_x86 +kmod-tpm
KCONFIG:= CONFIG_TCG_TIS
- FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm_tis.ko
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/tpm/tpm_tis.ko \
+ $(LINUX_DIR)/drivers/char/tpm/tpm_tis_core.ko
AUTOLOAD:=$(call AutoLoad,20,tpm_tis,1)
endef