aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2016-11-17 13:34:34 +0100
committerHans Dedecker <dedeckeh@gmail.com>2016-12-13 23:32:57 +0100
commita7c2310278c3554e78f26f6f84803669d9573dc6 (patch)
tree0e82ae39a16f65f28e01170f17d7d928e83d2f2b
parent942904f7b9363f231a9623d7d5501ae0cc7184d2 (diff)
downloadupstream-a7c2310278c3554e78f26f6f84803669d9573dc6.tar.gz
upstream-a7c2310278c3554e78f26f6f84803669d9573dc6.tar.bz2
upstream-a7c2310278c3554e78f26f6f84803669d9573dc6.zip
odhcpd: Fix dnsmasq re-reading hostfile
Depending on the dhcp uci config pidof dnsmasq can return multiple pids. Fix re-reading of the hostfile by dnsmasq in such case by sending SIGHUP signal to each of the returned pids. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
-rw-r--r--package/network/services/odhcpd/Makefile2
-rwxr-xr-xpackage/network/services/odhcpd/files/odhcpd-update5
2 files changed, 5 insertions, 2 deletions
diff --git a/package/network/services/odhcpd/Makefile b/package/network/services/odhcpd/Makefile
index f6ce26c150..4df0f77a25 100644
--- a/package/network/services/odhcpd/Makefile
+++ b/package/network/services/odhcpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcpd
-PKG_VERSION:=2016-11-21
+PKG_VERSION:=2016-12-13
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/package/network/services/odhcpd/files/odhcpd-update b/package/network/services/odhcpd/files/odhcpd-update
index e17cd0bfff..5f800aac60 100755
--- a/package/network/services/odhcpd/files/odhcpd-update
+++ b/package/network/services/odhcpd/files/odhcpd-update
@@ -2,4 +2,7 @@
# Make dnsmasq reread hostfile
pid=$(pidof dnsmasq)
-[ "$(readlink /proc/$pid/exe)" = "/usr/sbin/dnsmasq" ] && kill -SIGHUP $pid
+
+for i in $pid; do
+ [ "$(readlink /proc/$i/exe)" = "/usr/sbin/dnsmasq" ] && kill -SIGHUP $i
+done