aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-19 23:12:35 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-19 23:12:35 +0000
commita5ec491a09d7181d85d564d1db560587b84876f9 (patch)
treeb7b32bf02c07b6e08eaf74a539aa48c41f8a6064
parentc519093d573fe3f1143271ee3f98941f871891e9 (diff)
downloadupstream-a5ec491a09d7181d85d564d1db560587b84876f9.tar.gz
upstream-a5ec491a09d7181d85d564d1db560587b84876f9.tar.bz2
upstream-a5ec491a09d7181d85d564d1db560587b84876f9.zip
Use TARGET_CFLAGS, strip at package time
SVN-Revision: 983
-rw-r--r--openwrt/package/cifsmount/Makefile8
-rw-r--r--openwrt/package/robocfg/Makefile8
2 files changed, 8 insertions, 8 deletions
diff --git a/openwrt/package/cifsmount/Makefile b/openwrt/package/cifsmount/Makefile
index d0d186a8d3..2cb64d45fc 100644
--- a/openwrt/package/cifsmount/Makefile
+++ b/openwrt/package/cifsmount/Makefile
@@ -20,11 +20,11 @@ $(PKG_BUILD_DIR)/.configured:
touch $@
$(PKG_BUILD_DIR)/.built:
- $(TARGET_CC) -o $(PKG_BUILD_DIR)/mount.cifs mount.cifs.c
- $(STRIP) $(PKG_BUILD_DIR)/mount.cifs
+ $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mount.cifs mount.cifs.c
touch $@
$(IPKG_CIFSMOUNT):
- mkdir -p $(IDIR_CIFSMOUNT)/sbin
- install -m 0755 $(PKG_BUILD_DIR)/mount.cifs $(IDIR_CIFSMOUNT)/sbin/mount.cifs
+ install -d -m0755 $(IDIR_CIFSMOUNT)/sbin
+ install -m0755 $(PKG_BUILD_DIR)/mount.cifs $(IDIR_CIFSMOUNT)/sbin/
+ $(RSTRIP) $(IDIR_CIFSMOUNT)
$(IPKG_BUILD) $(IDIR_CIFSMOUNT) $(PACKAGE_DIR)
diff --git a/openwrt/package/robocfg/Makefile b/openwrt/package/robocfg/Makefile
index bc68f89058..6f511c0433 100644
--- a/openwrt/package/robocfg/Makefile
+++ b/openwrt/package/robocfg/Makefile
@@ -17,11 +17,11 @@ $(PKG_BUILD_DIR)/.prepared:
touch $@
$(PKG_BUILD_DIR)/.built:
- $(TARGET_CC) -o $(PKG_BUILD_DIR)/robocfg robocfg.c
- $(STRIP) $(PKG_BUILD_DIR)/robocfg
+ $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/robocfg robocfg.c
touch $@
$(IPKG_ROBOCFG):
- mkdir -p $(IDIR_ROBOCFG)/sbin
- install -m 0755 $(PKG_BUILD_DIR)/robocfg $(IDIR_ROBOCFG)/sbin/robocfg
+ install -d -m0755 $(IDIR_ROBOCFG)/sbin
+ install -m0755 $(PKG_BUILD_DIR)/robocfg $(IDIR_ROBOCFG)/sbin/
+ $(RSTRIP) $(IDIR_ROBOCFG)
$(IPKG_BUILD) $(IDIR_ROBOCFG) $(PACKAGE_DIR)