aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2020-06-02 09:16:49 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2020-06-02 09:16:49 +0200
commita47acae319c9b49c2737bbcc6302678d4706df3e (patch)
treeac13637abe26637ef3df5f52f6b4d0fd674208e9
parentf263a0f9ff5c050312f676b6684396ea118a8884 (diff)
downloadupstream-a47acae319c9b49c2737bbcc6302678d4706df3e.tar.gz
upstream-a47acae319c9b49c2737bbcc6302678d4706df3e.tar.bz2
upstream-a47acae319c9b49c2737bbcc6302678d4706df3e.zip
bcm63xx: ad1018: support Sercomm factory images
This images can be flashed from the official firmware, as opposed to CFE images, which can only be flashed from CFE and require opening the case. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
-rw-r--r--target/linux/bcm63xx/image/bcm63xx_nand.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/target/linux/bcm63xx/image/bcm63xx_nand.mk b/target/linux/bcm63xx/image/bcm63xx_nand.mk
index 57a895f9db..7dff893e4f 100644
--- a/target/linux/bcm63xx/image/bcm63xx_nand.mk
+++ b/target/linux/bcm63xx/image/bcm63xx_nand.mk
@@ -121,7 +121,7 @@ TARGET_DEVICES += netgear_dgnd3700-v2
### Sercomm ###
define Device/sercomm_ad1018
- $(Device/bcm63xx-nand)
+ $(Device/sercomm-nand)
IMAGE/cfe.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | ad1018-jffs2-cferam | append-ubi | cfe-wfi-tag
DEVICE_VENDOR := Sercomm
DEVICE_MODEL := AD1018
@@ -134,5 +134,15 @@ define Device/sercomm_ad1018
VID_HDR_OFFSET := 2048
DEVICE_PACKAGES += $(B43_PACKAGES) $(USB2_PACKAGES)
CFE_WFI_FLASH_TYPE := 3
+ SERCOMM_PID := \
+ 30 30 30 30 30 30 30 31 34 31 35 31 35 33 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 33 30 31 33 30 30 30 30 30 30 30 30 \
+ 0D 0A 00 00 00 00 00 00 00 00 00 00 00 00 00 00
+ SERCOMM_VERSION := 1001
endef
TARGET_DEVICES += sercomm_ad1018