aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-01-07 10:55:44 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-01-07 17:09:06 +0100
commita18f68ff3070cee50482e4bf3cc6bbf00f92f82b (patch)
treefa1bec624738723ad5a04c8d9ef3f6dc20c28e30
parent93c35bfa21a4d8cd66a4fe9218ba08088cb27ad2 (diff)
downloadupstream-a18f68ff3070cee50482e4bf3cc6bbf00f92f82b.tar.gz
upstream-a18f68ff3070cee50482e4bf3cc6bbf00f92f82b.tar.bz2
upstream-a18f68ff3070cee50482e4bf3cc6bbf00f92f82b.zip
kernel: bump 3.18 to 3.18.131
Refreshed all patches. Altered patches: - 902-debloat_proc.patch Compile-tested on: adm5120 Runtime-tested on: none Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/pending-3.18/834-ledtrig-libata.patch8
-rw-r--r--target/linux/generic/pending-3.18/902-debloat_proc.patch5
3 files changed, 9 insertions, 8 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index e80987972d..4d7397302e 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -2,12 +2,12 @@
LINUX_RELEASE?=1
-LINUX_VERSION-3.18 = .130
+LINUX_VERSION-3.18 = .131
LINUX_VERSION-4.9 = .146
LINUX_VERSION-4.14 = .90
LINUX_VERSION-4.19 = .9
-LINUX_KERNEL_HASH-3.18.130 = d1bf85ed3fd0067b1134178ed5492ae0053cb3fdd5361986fe0b85234fc82723
+LINUX_KERNEL_HASH-3.18.131 = 04600ce96e4c7642b9eaa4814f4930c79b53010b1c155d23e5ac0aeba6f455e2
LINUX_KERNEL_HASH-4.9.146 = 58195a8be3085d117c83a2ed1caa3b46ea7c1614c75f951b9f13f7adb03f8e59
LINUX_KERNEL_HASH-4.14.90 = 0c1ed0c93085e44ad89cd279647b0e4617d06ce5a482213b5481b612ffa186ca
LINUX_KERNEL_HASH-4.19.9 = fc116cc6829c73944215d3b3ac0fc368dde9e8235b456744afffde001269dbf2
diff --git a/target/linux/generic/pending-3.18/834-ledtrig-libata.patch b/target/linux/generic/pending-3.18/834-ledtrig-libata.patch
index 7a32e7f8ea..b956dedcce 100644
--- a/target/linux/generic/pending-3.18/834-ledtrig-libata.patch
+++ b/target/linux/generic/pending-3.18/834-ledtrig-libata.patch
@@ -69,7 +69,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
/**
* ata_build_rw_tf - Build ATA taskfile for given read/write request
* @tf: Target ATA taskfile
-@@ -4827,6 +4840,9 @@ static struct ata_queued_cmd *ata_qc_new
+@@ -4828,6 +4841,9 @@ static struct ata_queued_cmd *ata_qc_new
break;
}
}
@@ -79,7 +79,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
return qc;
}
-@@ -5736,6 +5752,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5737,6 +5753,9 @@ struct ata_port *ata_port_alloc(struct a
ap->stats.unhandled_irq = 1;
ap->stats.idle_irq = 1;
#endif
@@ -89,7 +89,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
ata_sff_port_init(ap);
return ap;
-@@ -5757,6 +5776,12 @@ static void ata_host_release(struct devi
+@@ -5758,6 +5777,12 @@ static void ata_host_release(struct devi
kfree(ap->pmp_link);
kfree(ap->slave_link);
@@ -102,7 +102,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
kfree(ap);
host->ports[i] = NULL;
}
-@@ -6203,7 +6228,23 @@ int ata_host_register(struct ata_host *h
+@@ -6204,7 +6229,23 @@ int ata_host_register(struct ata_host *h
host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
host->ports[i]->local_port_no = i + 1;
}
diff --git a/target/linux/generic/pending-3.18/902-debloat_proc.patch b/target/linux/generic/pending-3.18/902-debloat_proc.patch
index 69cf448414..c629d1020d 100644
--- a/target/linux/generic/pending-3.18/902-debloat_proc.patch
+++ b/target/linux/generic/pending-3.18/902-debloat_proc.patch
@@ -111,13 +111,14 @@
if (!root_irq_dir)
--- a/kernel/time/timer_list.c
+++ b/kernel/time/timer_list.c
-@@ -362,6 +362,8 @@ static int __init init_timer_list_procfs
+@@ -362,6 +362,9 @@ static int __init init_timer_list_procfs
{
struct proc_dir_entry *pe;
+ if (IS_ENABLED(CONFIG_PROC_STRIPPED))
+ return 0;
- pe = proc_create("timer_list", 0444, NULL, &timer_list_fops);
++
+ pe = proc_create("timer_list", 0400, NULL, &timer_list_fops);
if (!pe)
return -ENOMEM;
--- a/mm/vmalloc.c