aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-14 23:25:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-14 23:25:32 +0000
commita0a752a4774b94e8671645b2ce78638e93a08ec5 (patch)
treeb36e6d5bd9e328958438fb92e0bb34f716ddbe97
parent9737163928860d8f9c0371b71f385d0ec92b6906 (diff)
downloadupstream-a0a752a4774b94e8671645b2ce78638e93a08ec5.tar.gz
upstream-a0a752a4774b94e8671645b2ce78638e93a08ec5.tar.bz2
upstream-a0a752a4774b94e8671645b2ce78638e93a08ec5.zip
cleanup
SVN-Revision: 5106
-rw-r--r--target/utils/Makefile2
-rw-r--r--target/utils/src/trx.c12
2 files changed, 1 insertions, 13 deletions
diff --git a/target/utils/Makefile b/target/utils/Makefile
index f2a92fec3d..8412194e00 100644
--- a/target/utils/Makefile
+++ b/target/utils/Makefile
@@ -27,6 +27,6 @@ $(UTILS_BUILD_DIR):
mkdir -p $(UTILS_BUILD_DIR)
$(UTILS_BUILD_DIR)/%: src/%.c
- $(CC) -O2 -I $(STAGING_DIR)/include-host -o $@ $(patsubst $(UTILS_BUILD_DIR)/%,src/%.c,$@)
+ $(CC) -O2 -I $(STAGING_DIR)/include-host -include endian.h -o $@ $(patsubst $(UTILS_BUILD_DIR)/%,src/%.c,$@)
chmod 755 $@
diff --git a/target/utils/src/trx.c b/target/utils/src/trx.c
index abc9bc93c4..787ffa8946 100644
--- a/target/utils/src/trx.c
+++ b/target/utils/src/trx.c
@@ -44,18 +44,6 @@
#include <string.h>
#include <errno.h>
#include <unistd.h>
-#if defined(__APPLE__)
-#include <machine/endian.h>
-#include <machine/byte_order.h>
-#define __BYTE_ORDER BYTE_ORDER
-#define __BIG_ENDIAN BIG_ENDIAN
-#define bswap_16(x) NXSwapShort(x)
-#define bswap_32(x) NXSwapInt(x)
-#define bswap_64(x) NXSwapLongLong(x)
-#else
-#include <endian.h>
-#include <byteswap.h>
-#endif
#if __BYTE_ORDER == __BIG_ENDIAN
#define STORE32_LE(X) bswap_32(X)