aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-04-01 10:55:23 +0000
committerJohn Crispin <john@openwrt.org>2011-04-01 10:55:23 +0000
commit9fd342d91377b56426ae756689a32d2416df0914 (patch)
tree92bab64398cd3a7d4ecf792b6e52937843d116ba
parent33b864e899ce622b02cddcf78b142c81bcc3658a (diff)
downloadupstream-9fd342d91377b56426ae756689a32d2416df0914.tar.gz
upstream-9fd342d91377b56426ae756689a32d2416df0914.tar.bz2
upstream-9fd342d91377b56426ae756689a32d2416df0914.zip
r25831 reduced the size of the dropbear executable by, among other things,
disabling support for keyboard-interactive authentication. The default sshd configuration on Mac OS X only permits keyboard-interactive and public-key authentication, so unless a public key is set up, the default OpenWrt ssh client is now unable to connect to Mac OS X hosts. This patch re-enables keyboard-interactive authentication. In my tests, this increases the size of the stripped dropbear executable by 416 bytes on mips and 1,104 bytes on mipsel. In my opinion, such a small space savings isn't worthwhile when the resultant executable is severely hamstrung. Signed-off-by: Mark Mentovai <mark@moxienet.com> SVN-Revision: 26390
-rw-r--r--package/dropbear/Makefile2
-rw-r--r--package/dropbear/patches/120-openwrt_options.patch9
2 files changed, 1 insertions, 10 deletions
diff --git a/package/dropbear/Makefile b/package/dropbear/Makefile
index 736cf3945c..3fba1347ef 100644
--- a/package/dropbear/Makefile
+++ b/package/dropbear/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
PKG_VERSION:=0.53.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:= \
diff --git a/package/dropbear/patches/120-openwrt_options.patch b/package/dropbear/patches/120-openwrt_options.patch
index bfae5b9772..d1745e1e8d 100644
--- a/package/dropbear/patches/120-openwrt_options.patch
+++ b/package/dropbear/patches/120-openwrt_options.patch
@@ -56,15 +56,6 @@
/* The MOTD file path */
#ifndef MOTD_FILENAME
-@@ -177,7 +177,7 @@ much traffic. */
-
- #define ENABLE_CLI_PASSWORD_AUTH
- #define ENABLE_CLI_PUBKEY_AUTH
--#define ENABLE_CLI_INTERACT_AUTH
-+/*#define ENABLE_CLI_INTERACT_AUTH*/
-
- /* This variable can be used to set a password for client
- * authentication on the commandline. Beware of platforms
@@ -185,7 +185,7 @@ much traffic. */
* note that it will be provided for all "hidden" client-interactive
* style prompts - if you want something more sophisticated, use