diff options
author | Christian Marangi <ansuelsmth@gmail.com> | 2022-12-17 16:39:00 +0100 |
---|---|---|
committer | Hauke Mehrtens <hauke@hauke-m.de> | 2022-12-22 00:14:30 +0100 |
commit | 9aa95bbebb07554ccf6f611ead081f85e1f8b902 (patch) | |
tree | c9e2473e275f6740f03c300cee266008097afcec | |
parent | fcff234fd89e8b24aa3ad2f352ddbb5304c38dc1 (diff) | |
download | upstream-9aa95bbebb07554ccf6f611ead081f85e1f8b902.tar.gz upstream-9aa95bbebb07554ccf6f611ead081f85e1f8b902.tar.bz2 upstream-9aa95bbebb07554ccf6f611ead081f85e1f8b902.zip |
rules: fix broken commitcount on alpine system
To generate commitcount we use grep --max-count. This is not present on
alpine grep and cause wrong generation. Use -m as it's just the short
version of --max-count and more portable.
Fixes: #11200
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
(cherry picked from commit eb7ffeafbfa78235b05abb4ae479376150d7a814)
-rw-r--r-- | rules.mk | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -412,7 +412,7 @@ $(shell \ if git log -1 >/dev/null 2>/dev/null; then \ if [ -n "$(1)" ]; then \ last_bump="$$(git log --pretty=format:'%h %s' . | \ - grep --max-count=1 -e ': [uU]pdate to ' -e ': [bB]ump to ' | \ + grep -m 1 -e ': [uU]pdate to ' -e ': [bB]ump to ' | \ cut -f 1 -d ' ')"; \ fi; \ if [ -n "$$last_bump" ]; then \ |