aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2013-05-27 12:26:10 +0000
committerSteven Barth <steven@midlink.org>2013-05-27 12:26:10 +0000
commit9999ef34edd3da886514863ba607e00350dcd386 (patch)
tree8b953d5b839a80caaa2a24131e4a236f53ca912b
parentb443d33feda4fec3af9ac00f27f25598f7b1fdfe (diff)
downloadupstream-9999ef34edd3da886514863ba607e00350dcd386.tar.gz
upstream-9999ef34edd3da886514863ba607e00350dcd386.tar.bz2
upstream-9999ef34edd3da886514863ba607e00350dcd386.zip
AA: Update ipv6-support migration path
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36734 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/ipv6-support/Makefile9
-rwxr-xr-xpackage/ipv6-support/files/ipv6-boot15
-rwxr-xr-xpackage/ipv6-support/files/network-enable-ipv6.defaults23
3 files changed, 16 insertions, 31 deletions
diff --git a/package/ipv6-support/Makefile b/package/ipv6-support/Makefile
index efa2fb0fcf..5296233696 100644
--- a/package/ipv6-support/Makefile
+++ b/package/ipv6-support/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ipv6-support
-PKG_VERSION:=2013-05-23
+PKG_VERSION:=2013-05-27
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
@@ -16,8 +16,8 @@ include $(INCLUDE_DIR)/package.mk
define Package/ipv6-support
SECTION:=ipv6
CATEGORY:=IPv6
- DEPENDS:=+kmod-ipv6 +6relayd +odhcp6c +ip6tables
- TITLE:=Basic IPv6-support for Customer Edge Routers
+ DEPENDS:=+kmod-ipv6 +ip6tables +6relayd +odhcp6c +6in4 +6rd +6to4 +ds-lite
+ TITLE:=Extended IPv6-support for home routers (meta package)
MAINTAINER:=Steven Barth <steven@midlink.org>
PKGARCH:=all
endef
@@ -35,16 +35,13 @@ endef
define Package/ipv6-support/postinst
#!/bin/sh
-[ -n "$${IPKG_INSTROOT}" ] || /etc/init.d/ipv6-boot start || true
[ -n "$${IPKG_INSTROOT}" ] || /etc/uci-defaults/10_network-enable-ipv6 || true
[ -n "$${IPKG_INSTROOT}" ] || rm -f /etc/uci-defaults/10_network-enable-ipv6 || true
endef
define Package/ipv6-support/install
$(INSTALL_DIR) $(1)/etc/uci-defaults
- $(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/network-enable-ipv6.defaults $(1)/etc/uci-defaults/10_network-enable-ipv6
- $(INSTALL_BIN) ./files/ipv6-boot $(1)/etc/init.d/ipv6-boot
endef
$(eval $(call BuildPackage,ipv6-support))
diff --git a/package/ipv6-support/files/ipv6-boot b/package/ipv6-support/files/ipv6-boot
deleted file mode 100755
index a0d3856c03..0000000000
--- a/package/ipv6-support/files/ipv6-boot
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh /etc/rc.common
-START=11
-STOP=97
-
-start() {
- # early sysctl to avoid networking races
- if [ -d /proc/sys/net/ipv6/conf ]; then
- for i in /proc/sys/net/ipv6/conf/*/accept_ra; do
- echo 0 > $i
- done
-
- echo 1 > /proc/sys/net/ipv6/conf/default/forwarding
- echo 1 > /proc/sys/net/ipv6/conf/all/forwarding
- fi
-}
diff --git a/package/ipv6-support/files/network-enable-ipv6.defaults b/package/ipv6-support/files/network-enable-ipv6.defaults
index 7bde74267f..b2f94e0cd4 100755
--- a/package/ipv6-support/files/network-enable-ipv6.defaults
+++ b/package/ipv6-support/files/network-enable-ipv6.defaults
@@ -1,27 +1,30 @@
#!/bin/sh
-# Remove conflicting sysctl-handler
-rm -f /etc/hotplug.d/iface/10-sysctl
-
# Don't override existing settings
-uci get network.globals && exit 0
+uci -q get network.globals && exit 0
# Sometimes results are empty, therefore try until it works...
local r1 r2 r3
while [ -z "$r1" -o -z "$r2" -o -z "$r3" ]; do
- r1=$(printf "%02x" $(($(</dev/urandom tr -dc 0-9 | dd bs=9 count=1) % 256)))
- r2=$(printf "%01x" $(($(</dev/urandom tr -dc 0-9 | dd bs=9 count=1) % 65536)))
- r3=$(printf "%01x" $(($(</dev/urandom tr -dc 0-9 | dd bs=9 count=1) % 65536)))
+ r1=$(printf "%02x" $(($(</dev/urandom tr -dc 0-9 | dd bs=9 count=1 2>/dev/null) % 256)))
+ r2=$(printf "%01x" $(($(</dev/urandom tr -dc 0-9 | dd bs=9 count=1 2>/dev/null) % 65536)))
+ r3=$(printf "%01x" $(($(</dev/urandom tr -dc 0-9 | dd bs=9 count=1 2>/dev/null) % 65536)))
done
-
uci -q batch <<-EOF >/dev/null
set network.globals=globals
set network.globals.ula_prefix=fd$r1:$r2:$r3::/48
+ set network.lan.ip6assign=64
+ set network.wan.ipv6=1
+ commit network
+EOF
+
+
+# Set wan6 interface if non-existant
+uci -q get network.wan6 && exit 0
+uci -q batch <<-EOF >/dev/null
set network.wan6=interface
set network.wan6.proto=dhcpv6
set network.wan6.ifname=@wan
- set network.lan.ip6assign=64
- set network.wan.ipv6=1
commit network
EOF