aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-05-16 01:57:16 +0200
committerJohn Crispin <john@phrozen.org>2018-05-24 17:24:31 +0200
commit9361c359e4e1648f3ec3f541c51a1982d677f31d (patch)
treea6c2d0568b135c32bf0064931adbaedf39503c71
parent0411d3f65439af733bda8089e31ce53576f3ce4e (diff)
downloadupstream-9361c359e4e1648f3ec3f541c51a1982d677f31d.tar.gz
upstream-9361c359e4e1648f3ec3f541c51a1982d677f31d.tar.bz2
upstream-9361c359e4e1648f3ec3f541c51a1982d677f31d.zip
ipq40xx: add eva-image for FRITZ!Box 4040
This commit adds an EVA flashable image for the FRITZ!Box 4040. The image contains the U-Boot with OpenWRT appended to it. This way we remove the need to use UART for initial flashing. Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit 70e6ea319d3bfdfdb34be540dc7d89aa175b5587)
-rw-r--r--target/linux/ipq40xx/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index be396f92da..8ba2697e4f 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -80,7 +80,10 @@ define Device/avm_fritzbox-4040
BOARD_NAME := fritz4040
DEVICE_TITLE := AVM Fritz!Box 4040
IMAGE_SIZE := 29753344
- IMAGES = sysupgrade.bin
+ UBOOT_PATH := $$(BIN_DIR)/u-boot-fritz4040/uboot-fritz4040.bin
+ UBOOT_PARTITION_SIZE := 524288
+ IMAGES = eva.bin sysupgrade.bin
+ IMAGE/eva.bin := append-uboot | pad-to $$$$(UBOOT_PARTITION_SIZE) | append-kernel | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
DEVICE_PACKAGES := fritz-tffs fritz-caldata u-boot-fritz4040
endef