aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2016-10-23 14:56:09 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2016-10-23 14:56:09 +0200
commit920f92265207c8bfb24136c7245e1558cc8337ec (patch)
treebc94429315183d65a342558c134f65faeaa7b3ba
parent2187f57db6f55d41d68704179d309fbb6199b08e (diff)
downloadupstream-920f92265207c8bfb24136c7245e1558cc8337ec.tar.gz
upstream-920f92265207c8bfb24136c7245e1558cc8337ec.tar.bz2
upstream-920f92265207c8bfb24136c7245e1558cc8337ec.zip
kernel: update kernel 4.4 to version 4.4.27
Refresh patches for all targets that support kernel 4.4. compile/run-tested on brcm2708/bcm2710 only. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-4.4/903-debloat_direct_io.patch4
2 files changed, 4 insertions, 4 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index faf8ddeda6..5f64358d54 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .29
LINUX_VERSION-4.1 = .20
-LINUX_VERSION-4.4 = .26
+LINUX_VERSION-4.4 = .27
LINUX_KERNEL_MD5SUM-3.18.29 = b25737a0bc98e80d12200de93f239c28
LINUX_KERNEL_MD5SUM-4.1.20 = 075c38a3a23ca5bc80437b13606df00a
-LINUX_KERNEL_MD5SUM-4.4.26 = 0a3a2a719490d24f85591593913d3004
+LINUX_KERNEL_MD5SUM-4.4.27 = 6c437dd8f9e964c843211cf99a876b42724fe9f2013241c13e14b6ce17846afd
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/generic/patches-4.4/903-debloat_direct_io.patch b/target/linux/generic/patches-4.4/903-debloat_direct_io.patch
index afdc48b92c..7f6c529940 100644
--- a/target/linux/generic/patches-4.4/903-debloat_direct_io.patch
+++ b/target/linux/generic/patches-4.4/903-debloat_direct_io.patch
@@ -26,7 +26,7 @@
endif
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
-@@ -2716,6 +2716,7 @@ enum {
+@@ -2717,6 +2717,7 @@ enum {
DIO_SKIP_DIO_COUNT = 0x08,
};
@@ -34,7 +34,7 @@
void dio_end_io(struct bio *bio, int error);
ssize_t __blockdev_direct_IO(struct kiocb *iocb, struct inode *inode,
-@@ -2723,6 +2724,18 @@ ssize_t __blockdev_direct_IO(struct kioc
+@@ -2724,6 +2725,18 @@ ssize_t __blockdev_direct_IO(struct kioc
loff_t offset, get_block_t get_block,
dio_iodone_t end_io, dio_submit_t submit_io,
int flags);