aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-11 01:29:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-11 01:29:11 +0000
commit9141e1f560684ac04b5f56f62306089622e1132c (patch)
tree179e804bd00f7d1bc831cc48bfb64921f75b3dfe
parentbee3dd6a1b79da40d437f53c0b4547f156843369 (diff)
downloadupstream-9141e1f560684ac04b5f56f62306089622e1132c.tar.gz
upstream-9141e1f560684ac04b5f56f62306089622e1132c.tar.bz2
upstream-9141e1f560684ac04b5f56f62306089622e1132c.zip
package/index: filter out the libc package from the index
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32187 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rwxr-xr-xscripts/ipkg-make-index.sh1
-rw-r--r--target/imagebuilder/files/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/scripts/ipkg-make-index.sh b/scripts/ipkg-make-index.sh
index 31b4327da3..cbfa450c0a 100755
--- a/scripts/ipkg-make-index.sh
+++ b/scripts/ipkg-make-index.sh
@@ -14,6 +14,7 @@ for pkg in `find $pkg_dir -name '*.ipk' | sort`; do
name="${pkg##*/}"
name="${name%%_*}"
[[ "$name" = "kernel" ]] && continue
+ [[ "$name" = "libc" ]] && continue
echo "Generating index for package $pkg" >&2
file_size=$(ls -l $pkg | awk '{print $5}')
md5sum=$(md5sum $pkg | awk '{print $1}')
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 803252b4b6..b0d0698acd 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -126,6 +126,7 @@ package_index: FORCE
package_install: FORCE
@echo
@echo Installing packages...
+ $(OPKG) install $(PACKAGE_DIR)/libc_*.ipk
$(OPKG) install $(PACKAGE_DIR)/kernel_*.ipk
$(OPKG) install $(BUILD_PACKAGES)
rm -f $(TARGET_DIR)/usr/lib/opkg/lists/*