aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-08-16 12:23:06 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-08-27 10:31:06 +0200
commit8fba3ebe889664dae421e03daf9c545c05d3e692 (patch)
tree8ca80bce700b8ffe594399e7430d95ae34e41ba7
parent9952c8cf40597f033f5522fc6a4a9076469bb63a (diff)
downloadupstream-8fba3ebe889664dae421e03daf9c545c05d3e692.tar.gz
upstream-8fba3ebe889664dae421e03daf9c545c05d3e692.tar.bz2
upstream-8fba3ebe889664dae421e03daf9c545c05d3e692.zip
kernel: bump 4.14 to 4.14.139
Refreshed all patches. Also add a missing symbol for x86 which got used now in this bump. - ISCSI_IBFT Compile-tested on: cns3xxx, x86_64 Runtime-tested on: cns3xxx, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/hack-4.14/902-debloat_proc.patch2
-rw-r--r--target/linux/x86/64/config-4.141
-rw-r--r--target/linux/x86/generic/config-4.141
-rw-r--r--target/linux/x86/geode/config-4.141
-rw-r--r--target/linux/x86/legacy/config-4.141
6 files changed, 7 insertions, 3 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index c23364985b..be6c08f83a 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-4.14 = .138
+LINUX_VERSION-4.14 = .139
-LINUX_KERNEL_HASH-4.14.138 = f250bd1de3a83c1f015f8e6e9bfa9f20eaef3dc24a6cd60116e49979314b837b
+LINUX_KERNEL_HASH-4.14.139 = 8c62d495444dba90200740ec770d274780b010e957cfc447f07999d717e37042
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/generic/hack-4.14/902-debloat_proc.patch b/target/linux/generic/hack-4.14/902-debloat_proc.patch
index 2a20058ed3..aedefb32b4 100644
--- a/target/linux/generic/hack-4.14/902-debloat_proc.patch
+++ b/target/linux/generic/hack-4.14/902-debloat_proc.patch
@@ -232,7 +232,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
return -ENOMEM;
--- a/mm/vmalloc.c
+++ b/mm/vmalloc.c
-@@ -2774,6 +2774,8 @@ static const struct file_operations proc
+@@ -2783,6 +2783,8 @@ static const struct file_operations proc
static int __init proc_vmalloc_init(void)
{
diff --git a/target/linux/x86/64/config-4.14 b/target/linux/x86/64/config-4.14
index 2aad5acc09..d4d464b61b 100644
--- a/target/linux/x86/64/config-4.14
+++ b/target/linux/x86/64/config-4.14
@@ -273,6 +273,7 @@ CONFIG_INTEL_SOC_DTS_THERMAL=y
# CONFIG_IOMMU_DEBUG is not set
CONFIG_IOSF_MBI=y
# CONFIG_IOSF_MBI_DEBUG is not set
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
CONFIG_KALLSYMS_ABSOLUTE_PERCPU=y
# CONFIG_KVM_DEBUG_FS is not set
diff --git a/target/linux/x86/generic/config-4.14 b/target/linux/x86/generic/config-4.14
index 92380f526d..1e31e117dd 100644
--- a/target/linux/x86/generic/config-4.14
+++ b/target/linux/x86/generic/config-4.14
@@ -214,6 +214,7 @@ CONFIG_IRQ_BYPASS_MANAGER=y
CONFIG_ISA=y
CONFIG_ISAPNP=y
CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
CONFIG_ISO9660_FS=y
# CONFIG_JOLIET is not set
diff --git a/target/linux/x86/geode/config-4.14 b/target/linux/x86/geode/config-4.14
index f75891cee7..796aba7cd2 100644
--- a/target/linux/x86/geode/config-4.14
+++ b/target/linux/x86/geode/config-4.14
@@ -73,6 +73,7 @@ CONFIG_IOSF_MBI=y
CONFIG_ISA=y
# CONFIG_ISAPNP is not set
CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
# CONFIG_LANCE is not set
CONFIG_LEDS_GPIO=y
diff --git a/target/linux/x86/legacy/config-4.14 b/target/linux/x86/legacy/config-4.14
index dab36d39fc..6fa2d083ab 100644
--- a/target/linux/x86/legacy/config-4.14
+++ b/target/linux/x86/legacy/config-4.14
@@ -133,6 +133,7 @@ CONFIG_IOSF_MBI=y
CONFIG_ISA=y
CONFIG_ISAPNP=y
CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
CONFIG_ISO9660_FS=y
# CONFIG_JOLIET is not set