aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-25 09:55:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-25 09:55:07 +0000
commit8cff3db9996c08e587fcfbfe893b19c29b77aa83 (patch)
tree2363a63aade38d8d6fc074296e3fe47a5f20c574
parent13f087cd5aae235234d0f8d43627b5a47fe7dd2e (diff)
downloadupstream-8cff3db9996c08e587fcfbfe893b19c29b77aa83.tar.gz
upstream-8cff3db9996c08e587fcfbfe893b19c29b77aa83.tar.bz2
upstream-8cff3db9996c08e587fcfbfe893b19c29b77aa83.zip
add nat module fix from #1772
SVN-Revision: 7727
-rw-r--r--include/netfilter.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 1c9c752f70..2ff30c2442 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -103,6 +103,7 @@ IPT_IPSET-$(CONFIG_IP_NF_TARGET_SET) += $(P_V4)ipt_SET
IPT_NAT-m :=
ifneq ($(NF_KMOD),1)
IPT_NAT-$(CONFIG_IP_NF_NAT) += $(P_V4)ipt_SNAT $(P_V4)ipt_DNAT
+ IPT_NAT-$(CONFIG_NF_NAT) += $(P_V4)ipt_SNAT $(P_V4)ipt_DNAT
endif
IPT_NAT-$(CONFIG_IP_NF_TARGET_MASQUERADE) += $(P_V4)ipt_MASQUERADE
IPT_NAT-$(CONFIG_IP_NF_TARGET_MIRROR) += $(P_V4)ipt_MIRROR