aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-01-29 15:00:36 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-01-29 15:00:36 +0000
commit8c4813b75e7f77ef7f1853a883e3019d0b688ee1 (patch)
treec1300ee45e7140edb811568d302c447c07246886
parent0bb50678de160e7a5fba2fb72c27d56650888c9c (diff)
downloadupstream-8c4813b75e7f77ef7f1853a883e3019d0b688ee1.tar.gz
upstream-8c4813b75e7f77ef7f1853a883e3019d0b688ee1.tar.bz2
upstream-8c4813b75e7f77ef7f1853a883e3019d0b688ee1.zip
add default and Sim.One profiles
SVN-Revision: 29942
-rw-r--r--target/linux/ep93xx/profiles/00-default.mk17
-rw-r--r--target/linux/ep93xx/profiles/01-simone.mk22
2 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ep93xx/profiles/00-default.mk b/target/linux/ep93xx/profiles/00-default.mk
new file mode 100644
index 0000000000..1c43dc6587
--- /dev/null
+++ b/target/linux/ep93xx/profiles/00-default.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:= \
+ kmod-usb-core kmod-usb-ohci
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most EP93xx-based boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/ep93xx/profiles/01-simone.mk b/target/linux/ep93xx/profiles/01-simone.mk
new file mode 100644
index 0000000000..d13f37b188
--- /dev/null
+++ b/target/linux/ep93xx/profiles/01-simone.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Simone
+ NAME:=Simplemachines Sim.One
+ PACKAGES:= \
+ kmod-input-core \
+ kmod-input-evdev \
+ kmod-input-keyboard-ep93xx \
+ kmod-sound-soc-ep93xx \
+ kmod-sound-soc-ep93xx-ac97 \
+ kmod-sound-soc-ep93xx-simone
+endef
+
+define Profile/Simone/Description
+ Package set compatible with the Simplemachines Sim.One board.
+endef
+$(eval $(call Profile,Simone))