aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2018-11-28 21:53:02 +0100
committerMathias Kresin <dev@kresin.me>2018-11-28 23:37:29 +0100
commit8ba6e95eed4676aa38cb367d2ecbf6e09270d2cb (patch)
tree761bd60e08a39b428f9400069a96e8959875e579
parent26ad3571921e3456361afe6df10f66c176f18c18 (diff)
downloadupstream-8ba6e95eed4676aa38cb367d2ecbf6e09270d2cb.tar.gz
upstream-8ba6e95eed4676aa38cb367d2ecbf6e09270d2cb.tar.bz2
upstream-8ba6e95eed4676aa38cb367d2ecbf6e09270d2cb.zip
ramips: bdcom-wap2100: Enable mt7610e 5GHz radio
The 5GHz radio of this device uses an mt7610e PCI-E chip, which has been recently started to be supported. mt76x0e 0000:01:00.0: card - bus=0x1, slot = 0x0 irq=4 mt76x0e 0000:01:00.0: ASIC revision: 76100002 mt76x0e 0000:01:00.0: Firmware Version: 0.1.00 mt76x0e 0000:01:00.0: EEPROM ver:01 fae:00 Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--target/linux/ramips/dts/BDCOM-WAP2100-SK.dts12
-rw-r--r--target/linux/ramips/image/mt7620.mk2
2 files changed, 13 insertions, 1 deletions
diff --git a/target/linux/ramips/dts/BDCOM-WAP2100-SK.dts b/target/linux/ramips/dts/BDCOM-WAP2100-SK.dts
index a417c51470..6747f97ca1 100644
--- a/target/linux/ramips/dts/BDCOM-WAP2100-SK.dts
+++ b/target/linux/ramips/dts/BDCOM-WAP2100-SK.dts
@@ -130,6 +130,18 @@
ralink,mtd-eeprom = <&factory 0>;
};
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
+
&pinctrl {
state_default: pinctrl0 {
default {
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index a7aeaf130c..886ed62a3d 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -84,7 +84,7 @@ define Device/bdcom_wap2100-sk
DTS := BDCOM-WAP2100-SK
IMAGE_SIZE := 15808k
DEVICE_TITLE := BDCOM WAP2100-SK (ZTE ZXECS EBG3130)
- DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620 kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76x2 kmod-mt76x0e kmod-sdhci-mt7620 kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += bdcom_wap2100-sk