aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-03-25 18:09:37 +0100
committerMathias Kresin <dev@kresin.me>2017-04-08 14:30:00 +0200
commit8b3fa168b49a4aad5797ef5083c17c348d99731b (patch)
treed7eac940d191855a585876a1a8018549981ca04d
parent136718a3d91bb392de8bc04d9fd59d86b4f460c0 (diff)
downloadupstream-8b3fa168b49a4aad5797ef5083c17c348d99731b.tar.gz
upstream-8b3fa168b49a4aad5797ef5083c17c348d99731b.tar.bz2
upstream-8b3fa168b49a4aad5797ef5083c17c348d99731b.zip
firmware: rework fritz-tools package
Split the fritz-tools into subpackages. fritz_tffs_read is usefull for all Fritz boards where fritz-cal_extract is only required for the Fritz 4040 at the moment. Rename the tffs related binary to the more catchy name fritz_tffs and move the whole package to utilities since the package doesn't really provide a firmware file. Make the fritz-tools available for all targets and build them shared. The tffs is used by avm on lantiq and ar71xx as well. Tested-by: Christian Lamparter <chunkeey@googlemail.com> Signed-off-by: Mathias Kresin <dev@kresin.me>
-rw-r--r--package/firmware/fritz-tools/Makefile30
-rw-r--r--package/utils/fritz-tools/Makefile45
-rw-r--r--package/utils/fritz-tools/README.md (renamed from package/firmware/fritz-tools/README.md)0
-rw-r--r--package/utils/fritz-tools/src/CMakeLists.txt (renamed from package/firmware/fritz-tools/src/CMakeLists.txt)0
-rw-r--r--package/utils/fritz-tools/src/fritz_cal_extract.c (renamed from package/firmware/fritz-tools/src/fritz_cal_extract.c)0
-rw-r--r--package/utils/fritz-tools/src/fritz_tffs_read.c (renamed from package/firmware/fritz-tools/src/fritz_tffs_read.c)0
-rw-r--r--target/linux/ipq806x/image/Makefile2
7 files changed, 46 insertions, 31 deletions
diff --git a/package/firmware/fritz-tools/Makefile b/package/firmware/fritz-tools/Makefile
deleted file mode 100644
index 4891dcaca3..0000000000
--- a/package/firmware/fritz-tools/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=fritz-tools
-PKG_RELEASE:=1
-CMAKE_INSTALL:=1
-PKG_FLAGS:=nonshared
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-define Package/fritz-tools
- SECTION:=firmware
- CATEGORY:=Firmware
- DEPENDS:=@TARGET_ipq806x +zlib
- TITLE:=Utilites for accessing AVM Calibration data and TFFS
-endef
-
-define Package/fritz-tools/description
- This package contains:
- fritz_cal_extract.c: tool to extract WLAN calibration data.
- fritz_tffs_read.c: partially read the TFFS filesystems.
-endef
-
-define Package/fritz-tools/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/fritz_cal_extract $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/fritz_tffs_read $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,fritz-tools))
diff --git a/package/utils/fritz-tools/Makefile b/package/utils/fritz-tools/Makefile
new file mode 100644
index 0000000000..7c547e6f97
--- /dev/null
+++ b/package/utils/fritz-tools/Makefile
@@ -0,0 +1,45 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fritz-tools
+PKG_RELEASE:=1
+CMAKE_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/fritz-tools/Default
+ SECTION:=utils
+ CATEGORY:=Utilities
+endef
+
+define Package/fritz-tffs
+ $(call Package/fritz-tools/Default)
+ TITLE:=Utility to partially read the TFFS filesystems
+endef
+
+define Package/fritz-tffs/description
+ Utility to partially read the TFFS filesystems.
+endef
+
+define Package/fritz-caldata
+ $(call Package/fritz-tools/Default)
+ DEPENDS:=+zlib
+ TITLE:=Utility to extract WLAN calibration data
+endef
+
+define Package/fritz-caldata/description
+ Utility to extract the zlib compress calibration data from flash.
+endef
+
+define Package/fritz-tffs/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/fritz_tffs_read $(1)/usr/bin/fritz_tffs
+endef
+
+define Package/fritz-caldata/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/fritz_cal_extract $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,fritz-tffs))
+$(eval $(call BuildPackage,fritz-caldata))
diff --git a/package/firmware/fritz-tools/README.md b/package/utils/fritz-tools/README.md
index def237b174..def237b174 100644
--- a/package/firmware/fritz-tools/README.md
+++ b/package/utils/fritz-tools/README.md
diff --git a/package/firmware/fritz-tools/src/CMakeLists.txt b/package/utils/fritz-tools/src/CMakeLists.txt
index 116bca9dc0..116bca9dc0 100644
--- a/package/firmware/fritz-tools/src/CMakeLists.txt
+++ b/package/utils/fritz-tools/src/CMakeLists.txt
diff --git a/package/firmware/fritz-tools/src/fritz_cal_extract.c b/package/utils/fritz-tools/src/fritz_cal_extract.c
index 8156dfd1a7..8156dfd1a7 100644
--- a/package/firmware/fritz-tools/src/fritz_cal_extract.c
+++ b/package/utils/fritz-tools/src/fritz_cal_extract.c
diff --git a/package/firmware/fritz-tools/src/fritz_tffs_read.c b/package/utils/fritz-tools/src/fritz_tffs_read.c
index f367e02e04..f367e02e04 100644
--- a/package/firmware/fritz-tools/src/fritz_tffs_read.c
+++ b/package/utils/fritz-tools/src/fritz_tffs_read.c
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index f67e6b23ef..de6ddb6a93 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -181,7 +181,7 @@ define Device/FRITZ4040
IMAGE_SIZE := 29753344
IMAGES = sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
- DEVICE_PACKAGES := kmod-usb-phy-qcom-ipq4019 ipq-wifi-fritz4040 fritz-tools u-boot-fritz4040
+ DEVICE_PACKAGES := kmod-usb-phy-qcom-ipq4019 ipq-wifi-fritz4040 fritz-tffs fritz-caldata u-boot-fritz4040
endef
define Device/R7500