aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-01-04 22:19:28 +0800
committerFelix Fietkau <nbd@nbd.name>2017-01-05 11:09:14 +0100
commit8a2c56ca0326f944260f55fd03cafc34572dcba8 (patch)
treed82ba20659dc006c787b88ce2699ba4daa014451
parent4eb0fd8283940db6a92bbba47b12a236f6adee62 (diff)
downloadupstream-8a2c56ca0326f944260f55fd03cafc34572dcba8.tar.gz
upstream-8a2c56ca0326f944260f55fd03cafc34572dcba8.tar.bz2
upstream-8a2c56ca0326f944260f55fd03cafc34572dcba8.zip
sunxi: make sdcard image with squashfs as rootfs
Two things that need to be noted - There is no partition type id allocated for squashfs yet. In the case of sunxi, any non-zero value should work and we keep it 83 (the value for ext4) - Remaining spare space within the rootfs partition, not the entire sdcard space will be formated as either f2fs or ext4 and mounted as overlay to serve the role of rootfs_data. Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
-rw-r--r--target/linux/sunxi/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/sunxi/Makefile b/target/linux/sunxi/Makefile
index cca3a14896..b0bc1bab39 100644
--- a/target/linux/sunxi/Makefile
+++ b/target/linux/sunxi/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=sunxi
BOARDNAME:=Allwinner A1x/A20/A3x
-FEATURES:=fpu usb ext4 display rtc
+FEATURES:=fpu usb ext4 display rtc squashfs
CPU_TYPE:=cortex-a8
CPU_SUBTYPE:=vfpv3
MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
@@ -28,5 +28,6 @@ KERNELNAME:=zImage dtbs
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += uboot-envtools kmod-eeprom-sunxi kmod-wdt-sunxi
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
$(eval $(call BuildTarget))