aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-06-25 21:59:57 +0000
committerNicolas Thill <nico@openwrt.org>2006-06-25 21:59:57 +0000
commit89b019c77596710b004258755c603368c064c79e (patch)
treeb76e94b6f9815b53891fbe516d2525a537066e50
parent9da93d7b45f8e7f8892610a2ef233a089d77ca4b (diff)
downloadupstream-89b019c77596710b004258755c603368c064c79e.tar.gz
upstream-89b019c77596710b004258755c603368c064c79e.tar.bz2
upstream-89b019c77596710b004258755c603368c064c79e.zip
remove ref to host directories in config scripts.
SVN-Revision: 4082
-rw-r--r--openwrt/package/gnutls/Makefile2
-rw-r--r--openwrt/package/howl/Makefile4
-rw-r--r--openwrt/package/libpng/Makefile1
-rw-r--r--openwrt/package/libxslt/Makefile3
-rw-r--r--openwrt/package/speex/Makefile2
-rw-r--r--openwrt/package/sqlite/Makefile2
-rw-r--r--openwrt/package/sqlite2/Makefile2
7 files changed, 15 insertions, 1 deletions
diff --git a/openwrt/package/gnutls/Makefile b/openwrt/package/gnutls/Makefile
index 5257850784..b02199fce1 100644
--- a/openwrt/package/gnutls/Makefile
+++ b/openwrt/package/gnutls/Makefile
@@ -108,6 +108,8 @@ $(STAGING_DIR)/usr/lib/libgnutls.so: $(PKG_BUILD_DIR)/.built
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc $(STAGING_DIR)/usr/lib/pkgconfig/
mkdir -p $(STAGING_DIR)/usr/share/aclocal
$(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libgnutls{,-extra}.m4 $(STAGING_DIR)/usr/share/aclocal/
+ $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc
+ $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc
touch $@
install-dev: $(STAGING_DIR)/usr/lib/libgnutls.so
diff --git a/openwrt/package/howl/Makefile b/openwrt/package/howl/Makefile
index 02d9b78f2b..32557c5f18 100644
--- a/openwrt/package/howl/Makefile
+++ b/openwrt/package/howl/Makefile
@@ -106,7 +106,9 @@ $(STAGING_DIR)/usr/lib/libhowl.so: $(PKG_BUILD_DIR)/.built
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{howl,mDNSResponder}.{a,so*} $(STAGING_DIR)/usr/lib/
mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/howl.pc $(STAGING_DIR)/usr/lib/pkgconfig/
- touch $(STAGING_DIR)/usr/lib/libhowl.so
+ $(SED) 's,-I/usr/include/howl,,g' $(STAGING_DIR)/usr/lib/pkgconfig/howl.pc
+ $(SED) 's,-L/usr/lib,,g' $(STAGING_DIR)/usr/lib/pkgconfig/howl.pc
+ touch $@
install-dev: $(STAGING_DIR)/usr/lib/libhowl.so
diff --git a/openwrt/package/libpng/Makefile b/openwrt/package/libpng/Makefile
index 8033d42c41..2c6aebba0e 100644
--- a/openwrt/package/libpng/Makefile
+++ b/openwrt/package/libpng/Makefile
@@ -74,6 +74,7 @@ $(STAGING_DIR)/usr/lib/libpng.so: $(PKG_BUILD_DIR)/.built
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpng{,12}.{a,so*} $(STAGING_DIR)/usr/lib/
mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libpng{,12}.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+ $(SED) 's,-I$${includedir}/libpng12,,g' $(STAGING_DIR)/usr/lib/pkgconfig/libpng{,12}.pc
$(SED) 's,^[ILR]_opts=".\+",,g' $(STAGING_DIR)/usr/bin/libpng*-config
touch $@
diff --git a/openwrt/package/libxslt/Makefile b/openwrt/package/libxslt/Makefile
index dc6544810f..a187f538cd 100644
--- a/openwrt/package/libxslt/Makefile
+++ b/openwrt/package/libxslt/Makefile
@@ -87,6 +87,9 @@ $(STAGING_DIR)/usr/lib/libxslt.so: $(PKG_BUILD_DIR)/.built
$(SED) 's,-I$(STAGING_DIR)/usr/include,,g' $(STAGING_DIR)/usr/bin/xslt-config
$(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/bin/xslt-config
$(SED) 's,-L$(STAGING_DIR)/usr/lib,,g' $(STAGING_DIR)/usr/bin/xslt-config
+ $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/libxslt.pc
+ $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/libxslt.pc
+ $(SED) 's,-L$(STAGING_DIR)/usr/lib,,g' $(STAGING_DIR)/usr/lib/pkgconfig/libxslt.pc
touch $@
install-dev: $(STAGING_DIR)/usr/lib/libxslt.so
diff --git a/openwrt/package/speex/Makefile b/openwrt/package/speex/Makefile
index 87a3de9679..903966b516 100644
--- a/openwrt/package/speex/Makefile
+++ b/openwrt/package/speex/Makefile
@@ -72,6 +72,8 @@ $(STAGING_DIR)/usr/lib/libspeex.so: $(PKG_BUILD_DIR)/.built
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.{a,so*} $(STAGING_DIR)/usr/lib/
mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speex.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+ $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/speex.pc
+ $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/speex.pc
touch $@
install-dev: $(STAGING_DIR)/usr/lib/libspeex.so
diff --git a/openwrt/package/sqlite/Makefile b/openwrt/package/sqlite/Makefile
index b505bd9566..003f478371 100644
--- a/openwrt/package/sqlite/Makefile
+++ b/openwrt/package/sqlite/Makefile
@@ -84,6 +84,8 @@ $(STAGING_DIR)/usr/lib/libsqlite3.so: $(PKG_BUILD_DIR)/.built
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite3.{a,so*} $(STAGING_DIR)/usr/lib/
mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite3.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+ $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/sqlite3.pc
+ $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/sqlite3.pc
touch $@
install-dev: $(STAGING_DIR)/usr/lib/libsqlite3.so
diff --git a/openwrt/package/sqlite2/Makefile b/openwrt/package/sqlite2/Makefile
index 41a7382c96..6db13ddbb1 100644
--- a/openwrt/package/sqlite2/Makefile
+++ b/openwrt/package/sqlite2/Makefile
@@ -83,6 +83,8 @@ $(STAGING_DIR)/usr/lib/libsqlite.so: $(PKG_BUILD_DIR)/.built
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite.{a,so*} $(STAGING_DIR)/usr/lib/
mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+ $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/sqlite.pc
+ $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/sqlite.pc
touch $@
install-dev: $(STAGING_DIR)/usr/lib/libsqlite.so