aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2017-12-22 00:23:07 -0300
committerJohn Crispin <john@phrozen.org>2018-02-13 11:56:40 +0100
commit887925b09801b18e316eb6b75aa69f0cff168d83 (patch)
tree03f1fdc4d3cb3017301d5bf56c7f61427e652294
parent7f61924dcb1842cdb8dc95a63032143326d44793 (diff)
downloadupstream-887925b09801b18e316eb6b75aa69f0cff168d83.tar.gz
upstream-887925b09801b18e316eb6b75aa69f0cff168d83.tar.bz2
upstream-887925b09801b18e316eb6b75aa69f0cff168d83.zip
ipq806x: support new location of USB PHY kernel module
PHY drivers were grouped into vendor specific directories by upstream commit 0b56e9a7e8358e59b21d8a425e463072bfae523c Signed-off-by: Luis Araneda <luaraneda@gmail.com>
-rw-r--r--target/linux/ipq806x/modules.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/ipq806x/modules.mk b/target/linux/ipq806x/modules.mk
index 6f1ca2d2a4..43f3c9cfe7 100644
--- a/target/linux/ipq806x/modules.mk
+++ b/target/linux/ipq806x/modules.mk
@@ -18,7 +18,9 @@ define KernelPackage/usb-phy-qcom-dwc3
TITLE:=DWC3 USB QCOM PHY driver
DEPENDS:=@TARGET_ipq806x +kmod-usb-dwc3-of-simple
KCONFIG:= CONFIG_PHY_QCOM_DWC3
- FILES:= $(LINUX_DIR)/drivers/phy/phy-qcom-dwc3.ko
+ FILES:= \
+ $(LINUX_DIR)/drivers/phy/phy-qcom-dwc3.ko@lt4.13 \
+ $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-dwc3.ko@ge4.13
AUTOLOAD:=$(call AutoLoad,45,phy-qcom-dwc3,1)
$(call AddDepends/usb)
endef