aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 20:04:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 20:04:43 +0000
commit87a88cebc798989ef7d36cc590d4a3cdd42134f0 (patch)
tree86f5d6cdd464f9cc8a791001fc4d29eb714522eb
parenta9d683ca912b2c4837b2e65909c09ca01babe3df (diff)
downloadupstream-87a88cebc798989ef7d36cc590d4a3cdd42134f0.tar.gz
upstream-87a88cebc798989ef7d36cc590d4a3cdd42134f0.tar.bz2
upstream-87a88cebc798989ef7d36cc590d4a3cdd42134f0.zip
adapt profiles for subtarget changes
SVN-Revision: 8695
-rw-r--r--include/target.mk8
-rw-r--r--target/linux/amazon/Makefile3
-rw-r--r--target/linux/amcc/Makefile3
-rw-r--r--target/linux/ar7/Makefile2
-rw-r--r--target/linux/at91/Makefile3
-rw-r--r--target/linux/atheros/Makefile3
-rw-r--r--target/linux/au1000/Makefile3
-rw-r--r--target/linux/avr32/Makefile3
-rw-r--r--target/linux/brcm-2.4/Makefile3
-rw-r--r--target/linux/brcm47xx/Makefile3
-rw-r--r--target/linux/brcm63xx/Makefile3
-rw-r--r--target/linux/etrax/Makefile3
-rw-r--r--target/linux/iop32x/Makefile3
-rw-r--r--target/linux/ixp4xx/Makefile3
-rw-r--r--target/linux/magicbox/Makefile3
-rw-r--r--target/linux/pxa/Makefile3
-rw-r--r--target/linux/rb532/Makefile3
-rw-r--r--target/linux/rdc/Makefile3
-rw-r--r--target/linux/sibyte/Makefile3
-rw-r--r--target/linux/uml/Makefile3
-rw-r--r--target/linux/x86/Makefile3
21 files changed, 6 insertions, 61 deletions
diff --git a/include/target.mk b/include/target.mk
index 42f484af9d..8f072d0cd8 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -70,13 +70,17 @@ define Profile
getvar "$(call shvar,Profile/$(1)/Description)"; \
echo "@@"; \
echo;
- ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(2),$(2)_)$(1))),y)
+ ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_)$(1))),y)
PROFILE=$(1)
endif
endef
-$(eval $(call shexport,Target/Description))
+-include $(PLATFORM_DIR)/profiles/*.mk
+ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+ -include $(PLATFORM_SUBDIR)/profiles/*.mk
+endif
+$(eval $(call shexport,Target/Description))
include $(INCLUDE_DIR)/kernel-version.mk
diff --git a/target/linux/amazon/Makefile b/target/linux/amazon/Makefile
index 17f9d96494..b8491c2fd2 100644
--- a/target/linux/amazon/Makefile
+++ b/target/linux/amazon/Makefile
@@ -20,7 +20,4 @@ endef
KERNELNAME:="uImage"
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/amcc/Makefile b/target/linux/amcc/Makefile
index a35783be41..d582d81915 100644
--- a/target/linux/amcc/Makefile
+++ b/target/linux/amcc/Makefile
@@ -19,7 +19,4 @@ define Target/Description
Build firmware images for the AMCC Taishan evaluation board
endef
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/ar7/Makefile b/target/linux/ar7/Makefile
index 772222ac75..a355356dd0 100644
--- a/target/linux/ar7/Makefile
+++ b/target/linux/ar7/Makefile
@@ -19,6 +19,4 @@ define Target/Description
Build firmware images for TI AR7 based routers
endef
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
index 7a9a1adcc3..dfa3bfbb65 100644
--- a/target/linux/at91/Makefile
+++ b/target/linux/at91/Makefile
@@ -22,7 +22,4 @@ define Target/Description
Build fimware images for Figment Design Labs VersaLink board.
endef
-#include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/atheros/Makefile b/target/linux/atheros/Makefile
index fc48efd5de..b1a2f570ae 100644
--- a/target/linux/atheros/Makefile
+++ b/target/linux/atheros/Makefile
@@ -21,7 +21,4 @@ define Target/Description
Build firmware images for Atheros SoC boards
endef
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
index f7dcb03ed6..278e617b1d 100644
--- a/target/linux/au1000/Makefile
+++ b/target/linux/au1000/Makefile
@@ -27,8 +27,5 @@ define Kernel/BuildImage
$(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
endef
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/avr32/Makefile b/target/linux/avr32/Makefile
index 01d5838fe4..5c7c0bca3c 100644
--- a/target/linux/avr32/Makefile
+++ b/target/linux/avr32/Makefile
@@ -18,7 +18,4 @@ define Target/Description
Build firmware images for ATNGW100 board
endef
-#include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/brcm-2.4/Makefile b/target/linux/brcm-2.4/Makefile
index da5cf6404f..d93e0b6b9b 100644
--- a/target/linux/brcm-2.4/Makefile
+++ b/target/linux/brcm-2.4/Makefile
@@ -22,7 +22,4 @@ define Target/Description
(e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
endef
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index 5804ee9768..b00d5d7401 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -21,7 +21,4 @@ define Target/Description
(e.g. Netgear WGT634U)
endef
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index 93670c6eed..0e08984617 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -19,7 +19,4 @@ define Target/Description
(e.g. Inventel Livebox, Siemens SE515)
endef
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/etrax/Makefile b/target/linux/etrax/Makefile
index c837550062..e644c652b5 100644
--- a/target/linux/etrax/Makefile
+++ b/target/linux/etrax/Makefile
@@ -34,9 +34,6 @@ define Kernel/Prepare
$(call Kernel/Prepare/Fox)
endef
-#include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
$(eval $(call RequireCommand,/usr/local/cris/gcc-cris, \
Please install the binary cris toolchain. \
diff --git a/target/linux/iop32x/Makefile b/target/linux/iop32x/Makefile
index c097955f34..df84078a3b 100644
--- a/target/linux/iop32x/Makefile
+++ b/target/linux/iop32x/Makefile
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.21.5
include $(INCLUDE_DIR)/target.mk
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index f68f62bc7d..6e945aba2c 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.21.6
include $(INCLUDE_DIR)/target.mk
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/magicbox/Makefile b/target/linux/magicbox/Makefile
index a20158b522..b130095624 100644
--- a/target/linux/magicbox/Makefile
+++ b/target/linux/magicbox/Makefile
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.22.4
include $(INCLUDE_DIR)/target.mk
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/pxa/Makefile b/target/linux/pxa/Makefile
index ad44af27e4..b5985ea74d 100644
--- a/target/linux/pxa/Makefile
+++ b/target/linux/pxa/Makefile
@@ -19,7 +19,4 @@ define Target/Description
Stub for boards based on intel PXA
endef
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/rb532/Makefile b/target/linux/rb532/Makefile
index 608f0aca14..c80449dc0f 100644
--- a/target/linux/rb532/Makefile
+++ b/target/linux/rb532/Makefile
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.22.4
include $(INCLUDE_DIR)/target.mk
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/rdc/Makefile b/target/linux/rdc/Makefile
index ac49adeb97..961df474c1 100644
--- a/target/linux/rdc/Makefile
+++ b/target/linux/rdc/Makefile
@@ -32,7 +32,4 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
endef
endif
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/sibyte/Makefile b/target/linux/sibyte/Makefile
index aa8acea1ce..52728da190 100644
--- a/target/linux/sibyte/Makefile
+++ b/target/linux/sibyte/Makefile
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.21.5
include $(INCLUDE_DIR)/target.mk
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))
diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index e31ef02bb7..bed9bc99eb 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -27,9 +27,6 @@ LINUX_VERSION:=2.6.22.4
include $(INCLUDE_DIR)/target.mk
-# include the profiles
--include profiles/*.mk
-
endif
$(eval $(call BuildTarget))
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 771fd191f9..d1e459ce81 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -16,8 +16,5 @@ LINUX_VERSION:=2.6.22.4
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
-# include the profiles
--include profiles/*.mk
-
$(eval $(call BuildTarget))