aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2022-03-15 12:40:40 +0100
committerRafał Miłecki <rafal@milecki.pl>2022-03-15 18:55:08 +0100
commit864bba55d8714a64abdf94cfb835450b8cd7789e (patch)
tree773864e71abf0f9f0f6f7e88910cd485cf48bb0c
parent92020d42425090d8e30554c41bed2d650263e06e (diff)
downloadupstream-864bba55d8714a64abdf94cfb835450b8cd7789e.tar.gz
upstream-864bba55d8714a64abdf94cfb835450b8cd7789e.tar.bz2
upstream-864bba55d8714a64abdf94cfb835450b8cd7789e.zip
uboot-bcm4908: use "xxd" from staging_dir
This fixes: bash: xxd: command not found on hosts without xxd installed. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 9dbca6bf6e6e088afd18fb532ed9135c21aec1cc) Fixes: 45b3f2aa0f57 ("uboot-bcm4908: add package with BCM4908 U-Boot")
-rw-r--r--package/boot/uboot-bcm4908/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/boot/uboot-bcm4908/Makefile b/package/boot/uboot-bcm4908/Makefile
index 489b4d69bf..dc862f4e32 100644
--- a/package/boot/uboot-bcm4908/Makefile
+++ b/package/boot/uboot-bcm4908/Makefile
@@ -32,10 +32,10 @@ define Build/Prepare
$(call Build/Prepare/Default)
mkdir -p $(PKG_BUILD_DIR)/include/generated/
( cd $(PKG_BUILD_DIR)/board/broadcom/bcmbca/httpd/html/ && \
- xxd -i index.html > ../../../../../include/generated/index.h && \
- xxd -i flashing.html > ../../../../../include/generated/flashing.h && \
- xxd -i fail.html > ../../../../../include/generated/fail.h && \
- xxd -i 404.html > ../../../../../include/generated/404.h )
+ $(STAGING_DIR_HOST)/bin/xxd -i index.html > ../../../../../include/generated/index.h && \
+ $(STAGING_DIR_HOST)/bin/xxd -i flashing.html > ../../../../../include/generated/flashing.h && \
+ $(STAGING_DIR_HOST)/bin/xxd -i fail.html > ../../../../../include/generated/fail.h && \
+ $(STAGING_DIR_HOST)/bin/xxd -i 404.html > ../../../../../include/generated/404.h )
endef
define Build/InstallDev