aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2021-03-01 20:59:04 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-19 15:30:01 +0100
commit863ce4f15f74a674f01ab47f445b362c113b113b (patch)
tree4fd2023702943403bb7836cde801c6530af693e4
parent10ffefe60299637bc592ec4ef0dde93e0e2e8344 (diff)
downloadupstream-863ce4f15f74a674f01ab47f445b362c113b113b.tar.gz
upstream-863ce4f15f74a674f01ab47f445b362c113b113b.tar.bz2
upstream-863ce4f15f74a674f01ab47f445b362c113b113b.zip
kernel/modules: relocate teql hotplug from iproute2 to kmod-sched
The link equalizer sch_teql.ko of package kmod-sched relies on a hotplug script historically included in iproute2's tc package. In previous discussion [1], consensus was the hotplug script is best located together with the module in kmod-sched, but this change was deferred at the time. Relocate the hotplug script now. This change also simplifies adding a tc variant for minimal size with reduced functionality. [1] https://github.com/openwrt/openwrt/pull/1627#issuecomment-447923636 Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
-rw-r--r--package/kernel/linux/files/hotplug-sched-teql.sh (renamed from package/network/utils/iproute2/files/15-teql)0
-rw-r--r--package/kernel/linux/modules/netsupport.mk7
-rw-r--r--package/network/utils/iproute2/Makefile2
3 files changed, 7 insertions, 2 deletions
diff --git a/package/network/utils/iproute2/files/15-teql b/package/kernel/linux/files/hotplug-sched-teql.sh
index a0c0e503aa..a0c0e503aa 100644
--- a/package/network/utils/iproute2/files/15-teql
+++ b/package/kernel/linux/files/hotplug-sched-teql.sh
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 6bc8ba664a..f14928e18e 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -916,6 +916,13 @@ define KernelPackage/sched/description
Extra kernel schedulers modules for IP traffic
endef
+SCHED_TEQL_HOTPLUG:=hotplug-sched-teql.sh
+
+define KernelPackage/sched/install
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files/$(SCHED_TEQL_HOTPLUG) $(1)/etc/hotplug.d/iface/15-teql
+endef
+
$(eval $(call KernelPackage,sched))
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 440e33069b..a20e81c75a 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -166,8 +166,6 @@ endef
define Package/tc/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
- $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
- $(INSTALL_BIN) ./files/15-teql $(1)/etc/hotplug.d/iface/
ifeq ($(SHARED_LIBS),y)
$(INSTALL_DIR) $(1)/usr/lib/tc
$(CP) $(PKG_BUILD_DIR)/tc/*.so $(1)/usr/lib/tc