aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-02-19 22:39:12 +0100
committerStijn Tintel <stijn@linux-ipv6.be>2018-02-19 23:52:45 +0100
commit858ff4f3e1877a4baf882788cfd99deab26fbb5e (patch)
treec70a58265ee21bb3f533eed38b27327b512628b3
parent8651f1149dc18f6c730ae20f36a91d4eb360a9b0 (diff)
downloadupstream-858ff4f3e1877a4baf882788cfd99deab26fbb5e.tar.gz
upstream-858ff4f3e1877a4baf882788cfd99deab26fbb5e.tar.bz2
upstream-858ff4f3e1877a4baf882788cfd99deab26fbb5e.zip
Revert "brcm2708: fix sdcard image"
This reverts commit 6c2e1ff80f52b939405fe0c14577c584602ae432. GNU gzip does not fail when the image filename already contains the .gz extension, this is a problem specific to pigz. Revert the commit, as we now gzip the image twice. Reported-by: Martin Schleier <drahemmaps@gmx.net> Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
-rw-r--r--target/linux/brcm2708/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 2d606e5649..9ea9a07a9d 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -50,8 +50,8 @@ define Device/Default
FILESYSTEMS := ext4
KERNEL := kernel-bin | kernel-img
KERNEL_IMG := kernel.img
- IMAGES := sdcard.img
- IMAGE/sdcard.img := boot-img | sdcard-img | gzip | append-metadata
+ IMAGES := sdcard.img.gz
+ IMAGE/sdcard.img.gz := boot-img | sdcard-img | gzip | append-metadata
endef
define Device/rpi