aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSander Vanheule <sander@svanheule.net>2020-11-04 10:21:17 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-11-25 16:34:56 +0100
commit8582e15616d3d42340810cb9c880825ccf87e1b0 (patch)
treed0267c1252f8a049402ae8e866174e1b3ed89983
parentab1584a797ad946585d3eb5498bce07829dabe5f (diff)
downloadupstream-8582e15616d3d42340810cb9c880825ccf87e1b0.tar.gz
upstream-8582e15616d3d42340810cb9c880825ccf87e1b0.tar.bz2
upstream-8582e15616d3d42340810cb9c880825ccf87e1b0.zip
rtl838x: drop custom mkimage build function
UIMAGE_MAGIC is now supported by Build/uImage, in addition to UIMAGE_NAME. This removes the need for a custom mkimage call, so let's remove it. Signed-off-by: Sander Vanheule <sander@svanheule.net>
-rw-r--r--target/linux/rtl838x/image/Makefile13
1 files changed, 1 insertions, 12 deletions
diff --git a/target/linux/rtl838x/image/Makefile b/target/linux/rtl838x/image/Makefile
index 51acd41c76..266759220f 100644
--- a/target/linux/rtl838x/image/Makefile
+++ b/target/linux/rtl838x/image/Makefile
@@ -7,16 +7,6 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR = 0x80000000
KERNEL_ENTRY = 0x80000400
-define Build/custom-uimage
- mkimage -A $(LINUX_KARCH) \
- -O linux -T kernel \
- -C gzip -a $(KERNEL_LOADADDR) $(if $(UIMAGE_MAGIC),-M $(UIMAGE_MAGIC),) \
- -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n '$(1)' -d $@ $@.new
- mv $@.new $@
-endef
-
-
define Device/Default
PROFILES = Default
KERNEL := kernel-bin | append-dtb | gzip | uImage gzip
@@ -35,8 +25,7 @@ define Device/allnet_all-sg8208m
DEVICE_VENDOR := ALLNET
DEVICE_MODEL := ALL-SG8208M
UIMAGE_MAGIC := 0x00000006
- KERNEL := kernel-bin | append-dtb | gzip | custom-uimage 2.2.2.0
- KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | custom-uimage 2.2.2.0
+ UIMAGE_NAME := 2.2.2.0
DEVICE_PACKAGES := ip-full ip-bridge kmod-gpio-button-hotplug tc
endef
TARGET_DEVICES += allnet_all-sg8208m