aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-20 02:30:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-20 02:30:36 +0000
commit84a0696c1ee5378fef9ec79b8e69cc7c2f0fa8a7 (patch)
tree60c38a0bd993154db8d166416a4b2a96f972f5ba
parentc606df6563b0969de226087bebae65ee361fb5e6 (diff)
downloadupstream-84a0696c1ee5378fef9ec79b8e69cc7c2f0fa8a7.tar.gz
upstream-84a0696c1ee5378fef9ec79b8e69cc7c2f0fa8a7.tar.bz2
upstream-84a0696c1ee5378fef9ec79b8e69cc7c2f0fa8a7.zip
add descriptions to the broadcom target profiles and export them to the target metadata (not presented in menuconfig yet)
SVN-Revision: 6137
-rw-r--r--include/kernel-build.mk7
-rwxr-xr-xscripts/metadata.pl8
-rw-r--r--target/linux/brcm-2.4/Makefile36
-rw-r--r--target/linux/brcm-2.6/Makefile8
4 files changed, 58 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 6d9c9d978d..9a1e36328b 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -206,10 +206,15 @@ endef
define Profile
$(eval $(call Profile/Default))
$(eval $(call Profile/$(1)))
+ $(eval $(call shexport,Profile/$(1)/Description))
DUMPINFO += \
echo "Target-Profile: $(1)"; \
echo "Target-Profile-Name: $(NAME)"; \
- echo "Target-Profile-Packages: $(PACKAGES)";
+ echo "Target-Profile-Packages: $(PACKAGES)"; \
+ echo "Target-Profile-Description:"; \
+ getvar "$(call shvar,Profile/$(1)/Description)"; \
+ echo "@@"; \
+ echo;
endef
$(eval $(call shexport,Target/Description))
diff --git a/scripts/metadata.pl b/scripts/metadata.pl
index 9434af0f9d..396954a2c7 100755
--- a/scripts/metadata.pl
+++ b/scripts/metadata.pl
@@ -45,6 +45,14 @@ sub parse_target_metadata() {
};
/^Target-Profile-Name:\s*(.+)\s*$/ and $profile->{name} = $1;
/^Target-Profile-Packages:\s*(.*)\s*$/ and $profile->{packages} = [ split(/\s+/, $1) ];
+ /^Target-Profile-Description:/ and do {
+ my $desc;
+ while (<>) {
+ last if /^@@/;
+ $desc .= $_;
+ }
+ $profile->{desc} = $desc;
+ };
}
foreach my $target (@target) {
@{$target->{profiles}} > 0 or $target->{profiles} = [
diff --git a/target/linux/brcm-2.4/Makefile b/target/linux/brcm-2.4/Makefile
index 82bfa1bf90..0091360c73 100644
--- a/target/linux/brcm-2.4/Makefile
+++ b/target/linux/brcm-2.4/Makefile
@@ -25,24 +25,40 @@ define Profile/Broadcom
NAME:=Generic, Broadcom WiFi (default)
PACKAGES:=kmod-brcm-wl wlc nas kmod-wlcompat
endef
+
+define Profile/Broadcom/Description
+ Default package set compatible with most BCM947xx hardware
+endef
$(eval $(call Profile,Broadcom))
define Profile/BroadcomMimo
NAME:=Generic, Broadcom WiFi (MIMO)
PACKAGES:=kmod-brcm-wl-mimo wlc nas kmod-wlcompat
endef
+
+define Profile/BroadcomMimo/Description
+ Default package set compatible with 802.11n (draft) hardware
+endef
$(eval $(call Profile,BroadcomMimo))
define Profile/Atheros
NAME:=Generic, Atheros WiFi
PACKAGES:=kmod-madwifi
endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
$(eval $(call Profile,Atheros))
define Profile/None
NAME:=Generic, No WiFi
PACKAGES:=
endef
+
+define Profile/None/Description
+ Package set without WiFi support
+endef
$(eval $(call Profile,None))
@@ -50,30 +66,50 @@ define Profile/WRT54G3G
NAME:=Linksys WRT54G3G
PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt wlc nas kmod-wlcompat
endef
+
+define Profile/WRT54G3G/Description
+ Package set optimized for the WRT54G3G with UMTS support
+endef
$(eval $(call Profile,WRT54G3G))
define Profile/WL500G
NAME:=ASUS WL-500g
PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-lp wlc nas kmod-wlcompat
endef
+
+define Profile/WL500G/Description
+ Package set optimized for the WL-500g with USB and parallel port support
+endef
$(eval $(call Profile,WL500G))
define Profile/WL500GD
NAME:=ASUS WL-500g Deluxe
PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-uhci kmod-usb2 wlc nas kmod-wlcompat
endef
+
+define Profile/WL500GD/Description
+ Package set optimized for the WL-500g Deluxe with USB support
+endef
$(eval $(call Profile,WL500GD))
define Profile/WL500GP
NAME:=ASUS WL-500g Premium
PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 wlc nas kmod-wlcompat
endef
+
+define Profile/WL500GP/Description
+ Package set optimized for the WL-500g Premium with USB support
+endef
$(eval $(call Profile,WL500GP))
define Profile/WLHDD
NAME:=WL-HDD
PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx wlc nas kmod-wlcompat
endef
+
+define Profile/WLHDD/Description
+ Package set optimized for the WL-HDD with USB and IDE support
+endef
$(eval $(call Profile,WLHDD))
$(eval $(call BuildKernel))
diff --git a/target/linux/brcm-2.6/Makefile b/target/linux/brcm-2.6/Makefile
index 0a2575913d..0d5533194e 100644
--- a/target/linux/brcm-2.6/Makefile
+++ b/target/linux/brcm-2.6/Makefile
@@ -23,12 +23,20 @@ define Profile/Atheros
NAME:=Atheros WiFi (default)
PACKAGES:=kmod-madwifi
endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
$(eval $(call Profile,Atheros))
define Profile/None
NAME:=No WiFi
PACKAGES:=
endef
+
+define Profile/None/Description
+ Package set without WiFi support
+endef
$(eval $(call Profile,None))
$(eval $(call BuildKernel))