aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-10-13 16:36:16 +0200
committerFelix Fietkau <nbd@nbd.name>2022-02-16 20:38:47 +0100
commit83bf22ba2e5853a5afc09585f76dc76c0d74ebea (patch)
tree0039dae18334cf9aeb4c9f075dd0c70fb67433e4
parent230ec4c69c301ea1dcd2b2f245995af76df5a695 (diff)
downloadupstream-83bf22ba2e5853a5afc09585f76dc76c0d74ebea.tar.gz
upstream-83bf22ba2e5853a5afc09585f76dc76c0d74ebea.tar.bz2
upstream-83bf22ba2e5853a5afc09585f76dc76c0d74ebea.zip
tools/fakeroot: explicitly pass CPP variable
For some reason, the generated configure script fails to properly set up the internal preprocessor command variable, causing the host OS check for Darwin to fail after the last update. Explicitly setting CPP fixes this issue Signed-off-by: Felix Fietkau <nbd@nbd.name> (cherry-picked from commit 48e209e5c5a76dd0ce4a2a8b014416dc988269a3)
-rw-r--r--tools/fakeroot/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/fakeroot/Makefile b/tools/fakeroot/Makefile
index e9daa4b6ad..5f10070eac 100644
--- a/tools/fakeroot/Makefile
+++ b/tools/fakeroot/Makefile
@@ -19,7 +19,8 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_VARS += \
ac_cv_header_sys_capability_h=no \
- ac_cv_func_capset=no
+ ac_cv_func_capset=no \
+ CPP="$(HOSTCC) -E"
HOST_CONFIGURE_ARGS += \
--with-ipc=tcp