aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-01-28 15:53:44 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-01-28 15:53:44 +0000
commit839f3ab0e72df77d6264349801cd7f512b567fe5 (patch)
tree8ae3df10c7b07333a2e1683e7964a8b80c9f7364
parentec41a6a08ce79da472372fde532136643153f752 (diff)
downloadupstream-839f3ab0e72df77d6264349801cd7f512b567fe5.tar.gz
upstream-839f3ab0e72df77d6264349801cd7f512b567fe5.tar.bz2
upstream-839f3ab0e72df77d6264349801cd7f512b567fe5.zip
firewall: flush conntrack table after changing interface rules
SVN-Revision: 35348
-rw-r--r--package/network/config/firewall/Makefile4
-rw-r--r--package/network/config/firewall/files/lib/core_interface.sh3
2 files changed, 5 insertions, 2 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index 1cfc734a32..fce0a808cd 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2012 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=56
+PKG_RELEASE:=57
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/firewall/files/lib/core_interface.sh b/package/network/config/firewall/files/lib/core_interface.sh
index 3d6718431f..7400e2d351 100644
--- a/package/network/config/firewall/files/lib/core_interface.sh
+++ b/package/network/config/firewall/files/lib/core_interface.sh
@@ -106,6 +106,9 @@ fw_configure_interface() {
fw $action $mode r PREROUTING ${chain}_notrack $ { -i "$ifname" $inet }
fw $action $mode n POSTROUTING ${chain}_nat $ { -o "$ifname" $onet }
+ # Flush conntrack table
+ echo f >/proc/net/nf_conntrack 2>/dev/null
+
lock -u /var/run/firewall-interface.lock
}