aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-01-07 00:40:52 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-01-07 00:40:52 +0000
commit82365ff8191a461435ae7b4c1eedca78d620a7a1 (patch)
tree1979fac625d7f20c4067398f6167b01fe5dfefa1
parent1a9afcd9e48b3ebc6090c8bf213de8dc98cc7f08 (diff)
downloadupstream-82365ff8191a461435ae7b4c1eedca78d620a7a1.tar.gz
upstream-82365ff8191a461435ae7b4c1eedca78d620a7a1.tar.bz2
upstream-82365ff8191a461435ae7b4c1eedca78d620a7a1.zip
Added wx200d, thanks Geoffrey Kruse, corrected typo in tmsnc/Config.in
SVN-Revision: 2849
-rw-r--r--openwrt/package/Config.in1
-rw-r--r--openwrt/package/Makefile2
-rw-r--r--openwrt/package/tmsnc/Config.in2
-rw-r--r--openwrt/package/wx200d/Config.in10
-rw-r--r--openwrt/package/wx200d/Makefile51
-rw-r--r--openwrt/package/wx200d/ipkg/wx200d.control7
6 files changed, 72 insertions, 1 deletions
diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 44e0a77922..320fd6cba9 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -155,6 +155,7 @@ source "package/wondershaper/Config.in"
source "package/wpa_supplicant/Config.in"
source "package/wput/Config.in"
source "package/wrt-radauth/Config.in"
+source "package/wx200d/Config.in"
source "package/xinetd/Config.in"
source "package/xsupplicant/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index ec8d517b6f..04551c234d 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -238,6 +238,7 @@ package-$(BR2_PACKAGE_WONDERSHAPER) += wondershaper
package-$(BR2_PACKAGE_WPA_SUPPLICANT) += wpa_supplicant
package-$(BR2_PACKAGE_WPUT) += wput
package-$(BR2_PACKAGE_WRT_RADAUTH) += wrt-radauth
+package-$(BR2_PAKCAGE_WX200D) += wx200d
package-$(BR2_PACKAGE_XINETD) += xinetd
package-$(BR2_PACKAGE_XSUPPLICANT) += xsupplicant
package-$(BR2_PACKAGE_ZLIB) += zlib
@@ -348,6 +349,7 @@ vtun-compile: zlib-compile openssl-compile liblzo-compile
wificonf-compile: wireless-tools-compile nvram-compile
wknock-compile: libpcap-compile
wpa_supplicant-compile: openssl-compile
+wx200d-compile: postgresql-compile
xsupplicant-compile: openssl-compile
asterisk-compile: bluez-libs-compile ncurses-compile openssl-compile
diff --git a/openwrt/package/tmsnc/Config.in b/openwrt/package/tmsnc/Config.in
index 73d8ed4889..0ebe5135ef 100644
--- a/openwrt/package/tmsnc/Config.in
+++ b/openwrt/package/tmsnc/Config.in
@@ -1,5 +1,5 @@
config BR2_PACKAGE_TMSNC
- tristate "tmsnc .................................. text-based MSN client"
+ tristate "tmsnc............................. text-based MSN client"
default m if CONFIG_DEVEL
help
TMSNC is a textbased (console) MSN client written in C.
diff --git a/openwrt/package/wx200d/Config.in b/openwrt/package/wx200d/Config.in
new file mode 100644
index 0000000000..b7e88ca4e2
--- /dev/null
+++ b/openwrt/package/wx200d/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_WX200D
+ prompt "wx200d............................ weather station data collector"
+ tristate
+ default m if CONFIG_DEVEL
+ help
+ wx200d is a weather station data collector and server daemon
+ for the WX200, WM918, WMR918 and WMR968 weather station
+ hardware.
+
+ http://wx200d.sourceforge.net/
diff --git a/openwrt/package/wx200d/Makefile b/openwrt/package/wx200d/Makefile
new file mode 100644
index 0000000000..a0eec3aacc
--- /dev/null
+++ b/openwrt/package/wx200d/Makefile
@@ -0,0 +1,51 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wx200d
+PKG_VERSION:=1.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=0f90c099dddcdd46ac568d707822ec4c
+PKG_SOURCE_URL:=@SF/wx200d
+PKG_SOURCE:=wx200d-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,WX200D,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+ (cd $(PKG_BUILD_DIR); \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --without-libiconv-prefix \
+ --without-libintl-prefix \
+ --disable-nls \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
+ CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR) -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT -DHASTZ"
+ touch $@
+
+$(IPKG_WX200D):
+ install -d -m0755 $(IDIR_WX200D)/usr/bin
+ install -m0644 $(PKG_BUILD_DIR)/wx200 \
+ $(PKG_BUILD_DIR)/wxstdout \
+ $(PKG_BUILD_DIR)/wxfilter \
+ $(PKG_BUILD_DIR)/wxdebug $(IDIR_WX200D)/usr/bin/
+ mkdir -p $(IDIR_WX200D)/usr/sbin/
+ install -m0644 $(PKG_BUILD_DIR)/wx200d \
+ $(PKG_BUILD_DIR)/wxread $(IDIR_WX200D)/usr/sbin/
+ $(RSTRIP) $(IDIR_WX200D)
+ $(IPKG_BUILD) $(IDIR_WX200D) $(PACKAGE_DIR)
diff --git a/openwrt/package/wx200d/ipkg/wx200d.control b/openwrt/package/wx200d/ipkg/wx200d.control
new file mode 100644
index 0000000000..717e50b58d
--- /dev/null
+++ b/openwrt/package/wx200d/ipkg/wx200d.control
@@ -0,0 +1,7 @@
+Package: wx200d
+Priority: optional
+Section: misc
+Maintainer: Name <gkruse@gmail.com>
+Source: http://
+Description:Utils for Oregon Scientific wx* and related weather stations
+Depends: libpq